Netrunner Home

[Work-Around fix] KDE Panel issues


#1

After updating from the Debian Testing repo today, the KDE Panel lost widgets (system tray, networks, and others) and left-clicking on the panel no longer functions.

This issue has been reported on; bugs.kde.org


#2

Confirmed. On top of that, right click on panel/desktop does not work either.


#3

I also face this KDE panel issues.
I would also add that search doesn’t work any more in the app menu.


#4

JFYI.
This should be tracked by upstream debian as it seems to me a packaging error: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=907262

People are reporting it working with unstable/sid.


#5

Yes, it’s a packaging issue, as noted here;
https://bugs.kde.org/show_bug.cgi?id=397875#c6

With the Synaptic Package Manager, I enabled the Debian unstable repo & updated only the Frameworks packages (52 pkgs on my pc/127 on another pc), then disabled the unstable repo & restarted the system. Now the KDE Panel is in full view again. Haven’t fully tested all the issues reported, but should have corrected most, if not all of them.

Synaptic: Status; -> Installed (upgradable) -> Quick Filter ‘frameworks’
Select all packages that are listed, right click & select ‘Mark for Upgrade’ then click ‘Apply’
Note: both my systems posted an error while trying to upgrade the 1st time… don’t recall what it was… some nonsense about broken packages and not being able to install/upgrade. I retried and all installed/upgraded without issue.

This photo doesn’t show ‘Installed (upgradable)’. However, it will show when updates are available.
[attachment=1135]

Perhaps, a safer way would be to wait for an update from the Debian Testing repo to correct the issue.
https://tracker.debian.org/pkg/plasma-framework


#6

I wasn’t sure which pkgs you mean by Frameworks. In Synaptic -> Installed -> filter ‘kf5’ : I upgraded those not yet at latest version, 4 I think, yielding maybe 36 updates for me.

This fixed the right-click but I still had some widgets not loading. I deleted ~/.config/plasma-org.kde.plasma.desktop-appletsrc and ~/.config/plasmashellrc just because these were mentioned somewhere, Presto! Seems everything works now.

Thanks bunches for your help :wink:


#7

Updating to Frameworks 5.49 partially solved the issues: all the widgets are now visible again on the panel but the widget menu does not show the cascading menu when clicking on it.


#8

Synaptic: Status; -> Installed (upgradable) -> Quick Filter ‘frameworks’
I update my quoted post to include this in more detail.


#9

I also had an issue I discovered on 1 system that I messed with prior to finding out about the Frameworks packaging mishap. I don’t recall what Widget package(s) I completely removed and then installed again. 2 that come to mind are;
libqt5widgets5 - Qt 5 widgets module
plasma-dataengines-addons - additional data engines for Plasma


#10

I’m surprised this isn’t a priority fix, but we are using Testing not Stable. You could roll back to known good or Stable?

The widgets menu is flaky for me. I just kill it and retry; it works like 1 out of 4. Not an issue, tho, because I seldom change this.

This morning I did all the other updates 5.47 -> 5.49. I don’t notice any changes, still working widgets flaky menu.


#11

Found out actually that the menu was not shown because I had set window focus stealing prevention to extreme. Setting it back to none solved the issue. So nothing to do with the framework update. Not sure this is a bug or a feature though …