Wrong Desktop Displayed at Startup

Hey Everybody!

Just got NetRunner and I love it! I am having some “customization frustration” though. :@

For whatever reason, every time I log in, desktop 3 is displayed. I can’t find any settings to specify the default desktop at startup. This is driving me NUTS!

I’ve been all over Google, all day…

Netrunner 13.12
Linux 3.11.0-15-generic x86_64
KDE 4.11.2

Do you have to set up a program to open the Desktop 3 If you хаве right click on the panel and set up to open on Desktop 1. If not Open the browser, right click on panel and choose the Open option on the desktop 1.

Are you having the same problem? Anybody else?
Nope. I am not starting any programs on desktop 3. When it first starts, there are no programs open and Desktop 3 is displayed.

I found this article…

I tried it but it’s not working for me.

[quote]At first, I’ve configured 4 virtual desktops with the “Different widgets for each desktop” option enabled and all using the Netrunner Desktop layout. As usual this configuration caused an issue with fresh sessions starting on Desktop 2 or 3 instead of Desktop 1, as usual I’ve solved it by renaming ~/.kde/share/config/kwinrc.

I’ld like to use 4 different folders named Desktop 1, Desktop 2, etc. Doing so my desktops would be well organized.[/quote]

@ http://forums.netrunner-os.com/showthread.php?tid=2947

Does anyone have anymore information on how to implement this fix?

Hmm… Are you leaving the session (logout, shutdown, restart) when on desktop 3 ?
If yes try to go to desktop 1 and leave the session then.

Usually Plasma tries to load the last known virtual desktop.

Tried that. I’ve tried with both “restore previous session” and “new blank session” enabled. No luck.

I’ve started another post in the kwin section of forum.kde.org

I’ll let you know if I find anything.

Hey Everybody,

It’s fixed! I got a procedure that worked for me on the KDE forums.

[quote]By removing that file you’ll esp. reduce the amount of VD to 1, so i’d first check whether your kwin settings are actually of any relevance:

  • move the file away (rename it)
  • restart “kwin --replace &”
  • run “kcmshell4 desktop” and ensure you’ve your regular amount of VDs
  • log out; log in
    -> outcome?

The virtual desktop is usually restored from ~/.kde[4]/share/config/session/kwin_<some_hash>, so you should check that file for the “desktop” (w/o trailing number) key and ensure it’s updated:
Run “kcmshell4 smserver” and ensure to “restore previous session” on login, not some saved one.[/quote]

Hopefully this will help someone.