back to Netrunner | back to Blue Systems

Wrong Repo List?


#1

Hi,

20 year Linux desktop end-user here (and yes Linux end-users really do exist). I’m just now trying-out netrunner, so I installed 19.08 (first Desktop, then Core) on my test box. When I tried to install plasma-wallpapers-addons, I got:

Failed to fetch http://cdn-fastly.deb.debian.org/debian/pool/main/k/kdeplasma-addons/plasma-wallpapers-addons_5.14.5-1_amd64.deb404 Not Found [IP: 151.101.68.204 80]

I looked in Debian Buster, and it is there. I tried installing theirs (debian official), but got a version conflict with Netrunner. So I looked at sources.list, and see you’ve listed some European repos rather than US repos for debian (even though I installed the location as USA)…some of which are returning 404 errors, and others lag behind the major debian repos.

So I’m really confused! What’s supposed to be in sources.list for 19.08? Are they supposed to be current with Debian Stable, or are they netrunner specific? If they are, wouldn’t that normally be done by the ranking of the list?

Hopelessly Lost,
Lance


#2

Plasma is debian official. It looks like a mirror problem. Have you tried apt update?


#3

Updating returns:

Repository '[http://cdn-fastly.deb.debian.org/debian](http://cdn-fastly.deb.debian.org/debian?fbclid=IwAR3AtQjVPO5AKlPeD8gxl2f4lR9Q1c9IaZfdBU2y3TZduWy5WyYf7kxNtSc) buster InRelease' changed its 'Version' value from '' to '10.1'Repository '[http://cdn-fastly.deb.debian.org/debian](https://l.facebook.com/l.php?u=http%3A%2F%2Fcdn-fastly.deb.debian.org%2Fdebian%3Ffbclid%3DIwAR3QSJuwaG7DlkNDCwh-V88tfL_rQ2GUp1meH2YcYXQi1KOZypYAY4X7Vyk&h=AT0XXMqIgRwzte1EtrCtg43f5rkaRsdvD_YDJFQMdD_GAPETpGbIgCkzVgcuxbpzXw_0AHSHvlC0DOpXIbYCq313OSpeBtby6no8kkG1qEJk-hQ2vA8MIYLWuCk) buster InRelease' changed its 'Suite' value from 'testing' to 'stable'This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.Repository '[http://cdn-fastly.deb.debian.org/debian](https://l.facebook.com/l.php?u=http%3A%2F%2Fcdn-fastly.deb.debian.org%2Fdebian%3Ffbclid%3DIwAR0e_q0kB1hKmO6TtuYKzYVgsBaaYQkraTdPbHxylIEghx_glhbz-GUEXiw&h=AT0XXMqIgRwzte1EtrCtg43f5rkaRsdvD_YDJFQMdD_GAPETpGbIgCkzVgcuxbpzXw_0AHSHvlC0DOpXIbYCq313OSpeBtby6no8kkG1qEJk-hQ2vA8MIYLWuCk) buster-updates InRelease' changed its 'Suite' value from 'testing-updates' to 'stable-updates'

So I exited Synaptic, went to the terminal, and saw:
This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
Do you want to accept these changes and continue updating from this repository? [y/N]

Answering yes a couple of times cleared-out the problem.

Thanks!