Netrunner Home

X server lockup


#1

I’ve recently done a fresh install of Rolling off of the latest image on the site. It’s working reasonably well except that I’m getting random lockups every so often. I restart the X server (ctl-alt-bksp) and log back in and carry on but of course I’ve lost what I was working on.
Here’s the log.

$ dmesg | grep segfault [13596.723495] Chrome_~dThread[24947]: segfault at 0 ip 00007f600592d1d3 sp 00007f6001a68b00 error 6 in libxul.so[7f6005924000+4a0d000] [13596.723776] Chrome_~dThread[29802]: segfault at 0 ip 00007f13305ee1d3 sp 00007f132c724b00 error 6 in libxul.so[7f13305e5000+4a0d000] [27391.856875] dolphin[5875]: segfault at 8 ip 00007f15942dc51c sp 00007ffc83fcfb10 error 4 in libQt5XcbQpa.so.5.11.2[7f15942d5000+d5000] [27391.908086] Chrome_~dThread[3047]: segfault at 0 ip 00007f5121c921d3 sp 00007f511ddc8b00 error 6 in libxul.so[7f5121c89000+4a0d000] [27391.908203] Chrome_~dThread[4930]: segfault at 0 ip 00007f3ca93dd1d3 sp 00007f3ca5518b00 error 6 in libxul.so[7f3ca93d4000+4a0d000]

Any suggestions?


#2

This seems to be a common bug in Firefox.

Here is the bug reports I’ve found so far.
https://bugzilla.mozilla.org/show_bug.cgi?id=1428346
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1766875

I would try disabling the plugins (extensions) first, and if stable start to re-enable them one at a time until you find the culprit.


#3

Thanks, I’ll give that a go. It sounds like a good approach because my other Netrunner PC doesn’t have this problem even though they’re both running Rolling.