back to Netrunner | back to Blue Systems

Yakuake won't automatically start at login


#1

Somehow, yakuake is not automatically started at login. Where should I look to get this fixed? I tried kde autostart, but that simply start the full console in the foreground.


#2

KDE Autostart is correct. You can put yakuake in there and make sure in settings it is set to not display the konsole when started.


#3

Did that, but it still opens the main window. Is there any config I’m missing?


#4

Does F12 open and close it?
Are you sure that yakuake just wasn’t set to Full Screen mode?
(bottom right of the yakuake window there is a circle with 3 lines, click it to open it to check.)

PS, hitting F12 will also force yakuake to exit full screen mode.

Have you removed any netrunner-settings-xxxxx or ds9-settings-xxxx packages?


#5

After I start it, F12 works fine. But I checked the packages you suggested, and indeed the autostart settings were apparently removed (I guess I removed some python package which automatically did that? Not sure). Reinstalling it added back the autostart entry, but still the windows drops down, despite the checkbox not being set:


#6

Ok. Could be an issue worth investigating further.
Can you close Yakuake and start it manually via Alt+F2 and entering yakuake.

Does it open the window again or open in the background?
Any change when you press the button in the panel?
What about the entry in the application menu?


#7

Starting it manually makes the window drop as well. Same from the application menu, independent of whether the checkbox is ticked or not. I also looked into .yakuakerc, and the option seems to be correctly set: OpenAfterStart=false


#8

Can you check before launching it again if maybe a process of yakuake is running in the background.
You can do so by pressing Ctrl+Esc and see the list of running applications.


#9

No background process according to the system monitor. I might just try to purge and reinstall.