your last update crashes

Netrunner 13-12 RC 64-Bit works fine…until today…your last update crashes…

Please try removing the package with sudo apt-get purge netrunner-artwork and make sure to remove /var/lib/dpkg/netrunner-artwork.postrm and /var/lib/dpkg/netrunner-artwork.preinst . After that try installing the package again.
We are sorry for the inconvience.

Thank you…that’s it! All works fine now…:slight_smile:
btw. Netrunner is my favorite Distri since 2 years…

http://www.pc-sicherheit.net/linux-anleitungen/tipps-tricks-netrunner-t3576.html

best regards…

By doing this: sudo apt-get purge netrunner-artwork
All desktop themes, there are only Oxygen Dark and Air are eliminated.

Then you have to reinstall:
sudo apt-get install netrunner-artwork

[color=#0000CD]The package that generates this problem is as follows:
netrunner-system
I leave here all that comes in the terminal to run it.[/color]

Leyendo la información de estado… Hecho
Se actualizarán los siguientes paquetes:
netrunner-system
1 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 0 B/90,7 kB de archivos.
Se utilizarán 1.024 B de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? S
(Leyendo la base de datos … 210934 ficheros o directorios instalados actualmente.)
Preparando para reemplazar netrunner-system 1.0.42 (usando …/netrunner-system_1.0.45_all.deb) …
Removing any system startup links for /etc/init.d/netrunner-system …
Dejando desviación de /etc/pulse/default.pa a /etc/pulse/default.pa.orig por netrunner-system' Desempaquetando el reemplazo de netrunner-system ... Eliminandodesviación de /etc/pulse/default.pa a /etc/pulse/default.pa.orig por netrunner-system’
dpkg-divert: error: renombrar obliga a sobreescribir /etc/pulse/default.pa' con un fichero distinto/etc/pulse/default.pa.orig’, no está permitido.
dpkg: aviso: el subproceso script de post-removal' antiguo devolvió el código de salida de error 2 dpkg: probando el script del nuevo paquete en su lugar... dpkg: error al procesar /var/cache/apt/archives/netrunner-system_1.0.45_all.deb (--unpack): no hay ningún script en la nueva versión del paquete - abandono Dejandodesviación de /etc/pulse/default.pa a /etc/pulse/default.pa.orig por netrunner-system’
Procesando disparadores para netrunner-default-settings …
Procesando disparadores para ureadahead …
Se encontraron errores al procesar:
/var/cache/apt/archives/netrunner-system_1.0.45_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Please for future references run the commands again with LC_ALL=C so for example

LC_ALL=C sudo apt-get upgrade

This will output the error untranslated and help us determin the problem.

In this particular case its the same as with netrunner-artwork. To fix it just

apt-get purge netrunner-system and make sure that /var/lib/dpkg/info/netrunner-system,* files are removed. Then reinstall the package.

We are sorry for the inconvience.

[color=#0000CD][size=medium]Running this command, this is the response of the terminal:[/size][/color]

[color=#0000CD]ghermain@- - - - -:[/color]~$ [color=#FF0000]LC_ALL=C sudo apt-get upgrade[/color]
[sudo] password for ghermain:
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages will be upgraded:
libibus-1.0-5 netrunner-system
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 145 kB/235 kB of archives.
After this operation, 1024 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://archive.ubuntu.com/ubuntu/ saucy-updates/main libibus-1.0-5 amd64 1.5.3-6ubuntu2.1 [145 kB]
Fetched 145 kB in 1s (112 kB/s)
(Reading database … 210936 files and directories currently installed.)
Preparing to replace libibus-1.0-5:amd64 1.5.3-6ubuntu2 (using …/libibus-1.0-5_1.5.3-6ubuntu2.1_amd64.deb) …
Unpacking replacement libibus-1.0-5:amd64 …
Preparing to replace netrunner-system 1.0.42 (using …/netrunner-system_1.0.45_all.deb) …
Removing any system startup links for /etc/init.d/netrunner-system …
Leaving ‘diversion of /etc/pulse/default.pa to /etc/pulse/default.pa.orig by netrunner-system’
Unpacking replacement netrunner-system …
Removing ‘diversion of /etc/pulse/default.pa to /etc/pulse/default.pa.orig by netrunner-system’
dpkg-divert: error: rename involves overwriting /etc/pulse/default.pa' with different file/etc/pulse/default.pa.orig’, not allowed
dpkg: warning: subprocess old post-removal script returned error exit status 2
dpkg: trying script from the new package instead …
dpkg: error processing /var/cache/apt/archives/netrunner-system_1.0.45_all.deb (–unpack):
there is no script in the new version of the package - giving up
Leaving ‘diversion of /etc/pulse/default.pa to /etc/pulse/default.pa.orig by netrunner-system’
Processing triggers for netrunner-default-settings …
Processing triggers for ureadahead …
Errors were encountered while processing:
/var/cache/apt/archives/netrunner-system_1.0.45_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

[color=#0000CD]Then I deleted the whole chain: [/color]/var/lib/dpkg/info/netrunner-system,* [color=#0000CD]and [/color]/var/lib/dpkg/info/netrunner-artwork, * [color=#0000CD]files are removed. Then reinstall the package:[/color] netrunner-artwork
[color=#0000CD]It seems the problem was corrected because when doing a[/color] sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade [color=#0000CD]this is the answer:[/color]

Reading package lists … done
Reading package lists … done
Building dependency tree
Reading state information … done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists … done
Building dependency tree
Reading state information … done
Calculating upgrade … ready
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[color=#0000CD]ghermain@- - - - -:[/color]

thank you but it seems that you have to do also this…
http://forums.netrunner-os.com/showthread.php?tid=2216&pid=4103#pid4103
however…my netrunner works…until the next update…