10-09-2016 Update went bust >>> black screen

I saw my taskbar notification that there was an update available, so I went ahead and did it (sudo pacman -Syyu). After the update my graphics went screwy and on reboot I ended up with a black screen (no cursor, no mouse) before the KDE login. I was able to Ctrl-Alt-F2 and got a terminal. I tried some of the stuff at https://forum.manjaro.org/t/stable-update-2016-10-09-kernels-manjaro-tools-deepin-nm-libreoffice-steam/10663/57, where black screens seemed to be an issue…
but no luck.
Checked my log (journalctl -xb) and there was sddm-greeter dump errors that google didn’t seem to lead me to solutions so I just restored my clonezilla backup and I’m back to my pre-update working state. …and standing by for now.
I guessing my problem might be related to my NVIDIA 304.xxx driver.

I apologize, I had no electricity (besides a generator), or internet access for 3 days due to hurricane Matthew so I didn’t get a chance to post the update announcement. There is an issue with the systemd update that causes an issue where the x-session might get lost. Did you follow the two links from the bug report to see if maybe there was an answer to your issue there: https://bugs.archlinux.org/task/51275

Note: there are also some issues with the 4.8.0 kernel series, please do not use this kernel until these are resolved.

Thanks and no worries. I didn’t get as far as those links; a little over my head anyways.

Perhaps this update announcement and this update recommendation will help.

I too lost the screen on updating, but on rebooting, was able to resume the update. I saw the above links only thereafter.

He already covered that Manjaro forum thread in his original post.

I actually didn’t get to the update recommendation, but I’m out of country for a few days anyways.
Should I try that when I get back?

It says basically the same thing as the top of the Manjaro’s update announcement forum post.
The only difference is it has you update the systemd packages first by themselves.

Well, I followed the update recommendation:
Pre-update, pacman -Q systemd showed I had systemd 231-1, so I did sudo pacman -Sy libsystemd systemd systemd-sysvcompat , after which pacman -Q systemd gave systemd 231-4, then I did sudo pacman -Syyu, answered yes to removing qtchooser. Rebooted.
Same problem as my original post: black screen (no cursor, no mouse) and doesn’t get to the KDE login. Ctrl-Alt-F2 gets the terminal and my log (journalctl -xb) and there still is sddm-greeter crashed and dumped core errors.

I’m still using the LTS kernel (4.4.21)
Any ideas?

Could you post the errors?

Hopefully there is nothing sensitive here :slight_smile:


I see lots of “unable” “failed” and “cannot”

Some googling led me to try “systemctl restart sddm”; but that still yields black screen. Tried various other things, but no luck.

Hmm, what drivers are you using for your gpu again?
This seems to be a bit concerning:

You could also try editing the /etc/sddm.conf to use a different theme.

Graphic info:

+------------------------------------------------------+ | NVIDIA-SMI 4.304... Driver Version: 304.132 | |-------------------------------+----------------------+----------------------+ | GPU Name | Bus-Id Disp. | Volatile Uncorr. ECC | | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. | |===============================+======================+======================| | 0 GeForce 6100 nForce 405 | 0000:00:0D.0 N/A | N/A | | N/A N/A N/A N/A / N/A | 0% 0MB / 62MB | N/A N/A | +-------------------------------+----------------------+----------------------+

Theme: I changed netrunner to both breeze and then maui; both still black screen.
Good night from Japan

Try adding sddm to the video group.

Reference: https://forums.gentoo.org/viewtopic-p-7849988.html
This person had the exact same error.

No luck: Here is what I’ve tried from that thread and others I found:

[color=#000000][size=small][font=Arial]Usermod -a -G video sddm[/font][/size][/color]

[color=#000000][size=small][font=Arial]I already had the /var/lib/sddm folder.[/font][/size][/color]

[color=#000000][size=small][font=Arial]remove both /var/lib/sddm/.cache and ~/.cache and see if it improves things.[/font][/size][/color]

[color=#000000][size=small][font=Arial]sddm-greeter --theme /usr/share/sddm/themes/breeze/ --test-mode[/font][/size][/color]
[color=#000000][size=small][font=Arial]Tried all five themes in that folder and all gave:[/font][/size][/color][color=#000000][size=small][font=Arial] QXcbConnection: Could not connect to display[/font][/size][/color]

[color=#000000][size=small][font=Arial]I changed the permissions for all the themes in /usr/share/sddm/themes/ to 777[/font][/size][/color]

[color=#000000][size=small][font=Arial]Nvidia-xconfig:[/font][/size][/color][color=#000000][size=small][font=Arial] created /etc/X11/xorg.conf file.[/font][/size][/color]

Never had this kind of problem before. I notice in googling, this has happened to others mainly in 2015, with intel graphics and other distros and themes. And some solution for some but not others. I’m guessing I could downgrade some package, but not sure which one yet.

This really sounds like a GPU driver issue.
Have you tried switching to the nouveau drivers or reconfiguring your /etc/X11/mhwd.d/nvidia.conf file (try different options out)?

Nouveau drivers have never worked on this nvidia card. I looked at /etc/X11/mhwd.d/nvidia.conf but don’t see anything obvious to try differently.

This post and the others around it seems to point to nvidia-304xx driver regression: https://forum.manjaro.org/t/testing-update-2016-10-02-kernels-manjaro-tools-deepin-nm-libreoffice-steam/10310/17

For now I’m going to restore my clonezilla clone and give this upgrade a rest for now. Maybe for my next step, it should be possible to “hold” the nvidia driver and get the other upgrades?


After I restored my system again to pre-update state, I held the nvidia driver (at version 304.131) by editing /etc/pacman.conf with this line:

IgnorePkg   = lib32-nvidia-304xx linux44-nvidia-304xx mhwd-nvidia-304xx nvidia-304xx-utils

…then did the updates per the manjaro update thread. All seems well. I just have to keep an eye out if the nvidia-304xx get fixed. For reference, Other posts at nvidia forum: https://devtalk.nvidia.com/default/topic/972001/linux/serious-regression-in-legacy-304xx-304-132-drivers/

Boy am I glad I started making clones with clonezillla!

Since I held back the nvidia updates, I was hoping the [Update] 2016-10-23 would go smoothly, but after the updates, system freezes: I do Ctrl-Alt f2 and check my journal and I see a “failed to load module nvidia”
Back to drawing board… :s in mean clonezilla restore.

@ chantan,
You should have held back the kernel from updating as well as the nvidia driver modules. Unfortunately, sometimes the drivers need to be updated along with the kernel even for point releases.

ahhhh, OK that makes sense. Could you confirm that I just need to add “linux” to the IgnorePkg line? Thats what I found here: https://www.digitalocean.com/community/tutorials/pacman-syu-kernel-update-solved-how-to-ignore-arch-kernel-upgrades