Auto-Logon - Missing Netrunner Menu icon missing

Just to chime in letting know about issues with recent updates.

  1. Auto-Logon went away after update and had to manually edit etc/sddm.conf file to bring it back. As still nothing in Settings to select auto-logon for desktop. So had to change false to true and add session and user as those where blank.

Are they overwriting user settings without prompting if we want new or keep old configs?



  1. For some reason the Netrunner Homerun menu icon has disappeared on panel. And location usr/share/pixmaps is the homerun.svgz is missing from there. Has it been moved? As searching but can’t find it in usr/share/pixmaps.

Found one in file:///home/usr/share/about-distro/netrunner-rolling-logo.svg But don’t know if that is the right one?
Seems to work.

The setting for auto login is in system settings under Startup and Shutdown > SDDM > Advanced.

This should update netrunner-rolling-default-settings-2015.09 and netrunner-rolling-system-settings.

sudo pacman -Syu --force

Sorry looked in there and somehow missed it. See it now.

What about netrunner-rolling-default-settings? As got that as one package upgrade yesterday.
Still need to force thru pacman?

Also had one package to build in Octopi kdeconnect-git- builds then just sits there at the end continue installing Y. With a Pacman is currently in use. And been 10mins now no progress.

OK, the package netrunner-rolling-default-settings-2015.09 was split up into two packages, I guess I’ll need to add a depends line to it for now you’ll need to install the netrunner-rolling-system-settings. The split is so that I have the ability to update some things but not others, this also allows me to implement new features without messing with what’s under /etc/skel.

It seems I have that icon in the system settings package, this is not right.
Give me a few minutes and I’ll correct what is in which package.

Thanks again for All Your Hard Work! :slight_smile:

OK, I fixed the packages.
You might not need to use force now

Also netrunner-rolling-default-settings-201x.xx now depends on netrunner-rolling-system-settings. :slight_smile:

You will notice some chanages and additions, nothing that should mess up your personal settings though.
There is now a Netrunner Panel as well as the default panel that comes with Plasma 5. Before had only our modified default panel I split this out so that users can have the other as well. There is also a new Kicker instance named Netrunner Menu, this was because kicker doesn’t have a way to change it’s default settings and favorites. This means if you change your menu there was no way to get back the netrunner defaults without manually making the changes, now you can just select Netrunner Menu from the alternatives list. I also fixed some issues in the netrunner default plasma shell to remove desktop lag, etc.

I hope you like the changes and additions.

Yes, the PKGBUILD for latest version of kdeconnect-git is broken ATM, I have restored our original package to the repository,

Checking still broken kdeconnect.git is broken no change.
Also now doing a sync and no matter if I use Muon or Octopi get conflicting packages
for Netrunner settings.

OK then, that’s because I had just moved some files out of netrunner-rolling-system-settings, into netrunner-rolling-default-settings-201x.xx. :slight_smile:

Use the force flag to fix this:

sudo pacman -Syu --force.

You also shouldn’t need to do this in the future. I finally have the right files in the right packages.


If you ever need help with anything technical, I’m usually in the #netrunner-os and #manjaro channels on freenode.

Okey Dokey thanks for all your help as pacman force worked fine.
Also so far strange Conky starting on wrong monitor seems to be behaving also.

So left with lnstalling Gnome-disks or finding a solution to having my external usb drives auto-mount on startup.

And thanks for the invite and will remember tho haven’t gone irc before.

Have a recurring after updates have to re-boot twice. As gets borked with right screen showing on left screen. And right screen showing black can launch and put apps there but can’t right-click the right monitor. Requires reboot and clears on it’s own.

When this is normal bootup

Some kind of strange Hickup I guess. Mesa? Compositor?

I’d go with the sometimes wonky KDE Plasma multi-display settings.

How do you like the new Netrunner Menu and Netrunner Panel options?

New? As had migrated from old iso KDE 4 following your transition thread to Plasma 5 a couple of months back.
Seems pretty much what I had last couple of months.

Liking the new Plasma 5 of doing things on the panel. Would be nice if the calendar popup could do appointments,etc…
Haven’t checked state of yaWP weather plasmoid and using the Yahoo one at the moment. And Gmail feed plasmoid is nice for emails without the need to have Firefox open.

Now just down to uninstalling programs like Virtualbox,Skype,Printers,Bluetooth,etc… and the k-suite Pim,Kontacts,etc… as don’t use any of those. So want to minimize size & time on updates.

See that removable drives is coming back in 5.5

KDE Plasma 5.5, which is expected to land on December 8, 2015.
Until then, we might still get a maintenance release, KDE Plasma 5.4.3, but that’s not sure.

Tho still miss Krunner able to grab and drag where you want it to popup instead of center top of screen.
Even had a setting popup under cursor.

OK, what I meant was:
right click on the menu and selecting alternatives there is now a Netrunner Menu option.
right click the panel, panel options, add panel now has a Netrunner Panel option.
this leaves the Plasma 5 upstream default kicker and Panel available.

Nope! Unless I’m doing it wrong? Did the force updated for Netrunner-Settings update.

Also just booted up first time. And my Auto-Logon is disabled and had to go back in and reset back on.
Displays was wonky again and had to adjust monitors. As where stacked ontop of each other.

You need to unlock the widgets first, then select alternatives, there will now also be another kicker entry called Netrunner Menu, there is a Netrunner Panel is under add panels now as well.

I also have the missing netrunner icon although a click in the missing icons place still works.
This is my Konsole screen display.

[gary@netrunner-pc ~]$ sudo pacman -Syu --force.
[sudo] password for gary:
pacman: unrecognized option ‘–force.’

Ahhh Ok then.

Added it but when trying out different ones. Going back to Netrunner Menu and loses icon.

Found one in /usr/share/about-distro/netrunner-rolling-logo.svg But don’t know if that is the right one?
Seems to work.