Boot Failure After Update

as you can see from the Xorg log shown above, because Radeon driver. The amdgpu driver does not work with the cards HD 7600G until 7700

OK, still mesa should be using Gallium not LLVM. Something is definitely not set up right.
Could you post your xorg.conf file?

xorg.conf does not exist for me!

EE) Fatal server error: (EE) Server is already active for display 0 If this server is no longer running, remove /tmp/.X0-lock and start again. (EE) (EE) Please consult the The X.Org Foundation support at http://wiki.x.org for help. (EE)

[code]udo X :1 -configure

X.Org X Server 1.17.2
Release Date: 2015-06-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.13.0-68-generic x86_64 Ubuntu
Current Operating System: Linux gerhard-desktop 4.5.0-040500-generic #201603140130 SMP Mon Mar 14 05:32:22 UTC 2016 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.5.0-040500-generic root=UUID=d7516120-12c6-4264-8688-92f61b6c005c ro noprompt quiet splash vt.handoff=7
Build Date: 12 November 2015 05:33:29PM
xorg-server 2:1.17.2-1ubuntu9.1 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.32.6
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.1.log”, Time: Sun Mar 20 21:41:52 2016
List of video drivers:
cirrus
savage
qxl
intel
siliconmotion
openchrome
r128
tdfx
ati
mach64
vmware
nouveau
mga
trident
neomagic
radeon
sisusb
vesa
fbdev
modesetting
(II) [KMS] Kernel modesetting enabled.
No devices to configure. Configuration failed.
(EE) Server terminated with error (2). Closing log file.
gerhard@gerhard-desktop:~$
[/code]

and now ?

this is my Graphic Card:

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7600G] [1002:9908] Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7600G] [1002:9908] Kernel driver in use: radeon 00:01.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Trinity HDMI Audio Controller [1002:9902]

X.Org X Server 1.17.2 Release Date: 2015-06-16 [ 63.795] X Protocol Version 11, Revision 0 [ 63.795] Build Operating System: Linux 3.13.0-68-generic x86_64 Ubuntu [ 63.795] Current Operating System: Linux gerhard-desktop 4.5.0-040500-generic #201603140130 SMP Mon Mar 14 05:32:22 UTC 2016 x86_64 [ 63.795] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.5.0-040500-generic root=UUID=d7516120-12c6-4264-8688-92f61b6c005c ro noprompt quiet splash vt.handoff=7 [ 63.796] Build Date: 12 November 2015 05:33:29PM [ 63.796] xorg-server 2:1.17.2-1ubuntu9.1 (For technical support please see http://www.ubuntu.com/support) [ 63.796] Current version of pixman: 0.32.6 [ 63.796] Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. [ 63.796] Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. [ 63.796] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Mar 20 20:41:48 2016 [ 63.797] (==) Using system config directory "/usr/share/X11/xorg.conf.d" [ 63.797] (==) No Layout section. Using the first Screen section. [ 63.797] (==) No screen section available. Using defaults. [ 63.797] (**) |-->Screen "Default Screen Section" (0) [ 63.797] (**) | |-->Monitor "<default monitor>" [ 63.797] (==) No monitor specified for screen "Default Screen Section". Using a default monitor configuration. [ 63.797] (==) Automatically adding devices [ 63.797] (==) Automatically enabling devices [ 63.797] (==) Automatically adding GPU devices [ 63.798] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist. [ 63.798] Entry deleted from font path. [ 63.798] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist. [ 63.798] Entry deleted from font path. [ 63.798] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist. [ 63.798] Entry deleted from font path. [ 63.798] (==) FontPath set to: /usr/share/fonts/X11/misc, /usr/share/fonts/X11/100dpi/:unscaled, /usr/share/fonts/X11/Type1, /usr/share/fonts/X11/100dpi, built-ins [ 63.798] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules" [ 63.798] (II) The server relies on udev to provide the list of input devices. If no devices become available, reconfigure udev or disable AutoAddDevices. [ 63.798] (II) Loader magic: 0x558bc4289d40 [ 63.798] (II) Module ABI versions: [ 63.798] X.Org ANSI C Emulation: 0.4 [ 63.798] X.Org Video Driver: 19.0 [ 63.798] X.Org XInput driver : 21.0 [ 63.798] X.Org Server Extension : 9.0 [ 63.799] (II) xfree86: Adding drm device (/dev/dri/card0) [ 63.801] (--) PCI:*(0:0:1:0) 1002:9908:1002:9908 rev 0, Mem @ 0xc0000000/268435456, 0xfeb00000/262144, I/O @ 0x0000f000/256 [ 63.801] (II) LoadModule: "glx" [ 63.802] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so [ 63.803] (II) Module glx: vendor="X.Org Foundation" [ 63.803] compiled for 1.17.2, module version = 1.0.0 [ 63.803] ABI class: X.Org Server Extension, version 9.0 [ 63.803] (==) AIGLX enabled [ 63.803] (==) Matched fglrx as autoconfigured driver 0 [ 63.803] (==) Matched ati as autoconfigured driver 1 [ 63.803] (==) Matched fglrx as autoconfigured driver 2 [ 63.803] (==) Matched ati as autoconfigured driver 3 [ 63.803] (==) Matched modesetting as autoconfigured driver 4 [ 63.803] (==) Matched fbdev as autoconfigured driver 5 [ 63.803] (==) Matched vesa as autoconfigured driver 6 [ 63.803] (==) Assigned the driver to the xf86ConfigLayout [ 63.803] (II) LoadModule: "fglrx" [ 63.804] (WW) Warning, couldn't open module fglrx [ 63.804] (II) UnloadModule: "fglrx" [ 63.804] (II) Unloading fglrx [ 63.804] (EE) Failed to load module "fglrx" (module does not exist, 0) [ 63.804] (II) LoadModule: "ati" [ 63.804] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so [ 63.804] (II) Module ati: vendor="X.Org Foundation" [ 63.804] compiled for 1.17.2, module version = 7.6.99 [ 63.804] Module class: X.Org Video Driver [ 63.804] ABI class: X.Org Video Driver, version 19.0 [ 63.804] (II) LoadModule: "radeon" [ 63.805] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so [ 63.805] (II) Module radeon: vendor="X.Org Foundation" [ 63.805] compiled for 1.17.2, module version = 7.6.99 [ 63.805] Module class: X.Org Video Driver [ 63.805] ABI class: X.Org Video Driver, version 19.0 [ 63.805] (II) LoadModule: "modesetting" [ 63.805] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so [ 63.805] (II) Module modesetting: vendor="X.Org Foundation" [ 63.805] compiled for 1.17.2, module version = 1.17.2 [ 63.806] Module class: X.Org Video Driver [ 63.806] ABI class: X.Org Video Driver, version 19.0 [ 63.806] (II) LoadModule: "fbdev" [ 63.806] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so [ 63.806] (II) Module fbdev: vendor="X.Org Foundation" [ 63.806] compiled for 1.17.1, module version = 0.4.4 [ 63.806] Module class: X.Org Video Driver [ 63.806] ABI class: X.Org Video Driver, version 19.0 [ 63.806] (II) LoadModule: "vesa" [ 63.806] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so [ 63.806] (II) Module vesa: vendor="X.Org Foundation" [ 63.806] compiled for 1.17.1, module version = 2.3.4 [ 63.806] Module class: X.Org Video Driver [ 63.806] ABI class: X.Org Video Driver, version 19.0 [ 63.806] (==) Matched fglrx as autoconfigured driver 0 [ 63.806] (==) Matched ati as autoconfigured driver 1 [ 63.806] (==) Matched fglrx as autoconfigured driver 2 [ 63.806] (==) Matched ati as autoconfigured driver 3 [ 63.806] (==) Matched modesetting as autoconfigured driver 4 [ 63.806] (==) Matched fbdev as autoconfigured driver 5 [ 63.806] (==) Matched vesa as autoconfigured driver 6 [ 63.806] (==) Assigned the driver to the xf86ConfigLayout [ 63.806] (II) LoadModule: "fglrx" [ 63.807] (WW) Warning, couldn't open module fglrx [ 63.807] (II) UnloadModule: "fglrx" [ 63.807] (II) Unloading fglrx [ 63.807] (EE) Failed to load module "fglrx" (module does not exist, 0) [ 63.807] (II) LoadModule: "ati" [ 63.807] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so [ 63.807] (II) Module ati: vendor="X.Org Foundation" [ 63.807] compiled for 1.17.2, module version = 7.6.99 [ 63.807] Module class: X.Org Video Driver [ 63.807] ABI class: X.Org Video Driver, version 19.0 [ 63.807] (II) LoadModule: "modesetting" [ 63.808] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so [ 63.808] (II) Module modesetting: vendor="X.Org Foundation" [ 63.808] compiled for 1.17.2, module version = 1.17.2 [ 63.808] Module class: X.Org Video Driver [ 63.808] ABI class: X.Org Video Driver, version 19.0 [ 63.808] (II) UnloadModule: "modesetting" [ 63.808] (II) Unloading modesetting [ 63.808] (II) Failed to load module "modesetting" (already loaded, 0) [ 63.808] (II) LoadModule: "fbdev" [ 63.808] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so [ 63.808] (II) Module fbdev: vendor="X.Org Foundation" [ 63.808] compiled for 1.17.1, module version = 0.4.4 [ 63.808] Module class: X.Org Video Driver [ 63.808] ABI class: X.Org Video Driver, version 19.0 [ 63.808] (II) UnloadModule: "fbdev" [ 63.808] (II) Unloading fbdev [ 63.808] (II) Failed to load module "fbdev" (already loaded, 0) [ 63.808] (II) LoadModule: "vesa" [ 63.808] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so [ 63.808] (II) Module vesa: vendor="X.Org Foundation" [ 63.808] compiled for 1.17.1, module version = 2.3.4 [ 63.808] Module class: X.Org Video Driver [ 63.808] ABI class: X.Org Video Driver, version 19.0 [ 63.808] (II) UnloadModule: "vesa" [ 63.808] (II) Unloading vesa [ 63.809] (II) Failed to load module "vesa" (already loaded, 0)

63.819] (--) controlling tty is VT number 1, auto-enabling KeepTty [ 63.819] (II) [KMS] Kernel modesetting enabled. [ 63.819] (WW) Falling back to old probe method for modesetting [ 63.820] (WW) Falling back to old probe method for fbdev [ 63.820] (II) Loading sub module "fbdevhw" [ 63.820] (II) LoadModule: "fbdevhw" [ 63.820] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so [ 63.820] (II) Module fbdevhw: vendor="X.Org Foundation" [ 63.820] compiled for 1.17.2, module version = 0.0.2 [ 63.820] ABI class: X.Org Video Driver, version 19.0 [ 63.820] (WW) Falling back to old probe method for vesa [ 63.820] (II) RADEON(0): Creating default Display subsection in Screen section "Default Screen Section" for depth/fbbpp 24/32 [ 63.820] (==) RADEON(0): Depth 24, (--) framebuffer bpp 32 [ 63.820] (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps) [ 63.820] (==) RADEON(0): Default visual is TrueColor [ 63.820] (==) RADEON(0): RGB weight 888 [ 63.820] (II) RADEON(0): Using 8 bits per RGB (8 bit DAC) [ 63.820] (--) RADEON(0): Chipset: "ARUBA" (ChipID = 0x9908) [ 63.821] (II) Loading sub module "fb" [ 63.821] (II) LoadModule: "fb" [ 63.821] (II) Loading /usr/lib/xorg/modules/libfb.so [ 63.822] (II) Module fb: vendor="X.Org Foundation" [ 63.822] compiled for 1.17.2, module version = 1.0.0 [ 63.822] ABI class: X.Org ANSI C Emulation, version 0.4 [ 63.822] (II) Loading sub module "dri2" [ 63.822] (II) LoadModule: "dri2" [ 63.822] (II) Module "dri2" already built-in [ 63.822] (II) Loading sub module "exa" [ 63.822] (II) LoadModule: "exa" [ 63.822] (II) Loading /usr/lib/xorg/modules/libexa.so [ 63.823] (II) Module exa: vendor="X.Org Foundation" [ 63.823] compiled for 1.17.2, module version = 2.6.0 [ 63.823] ABI class: X.Org Video Driver, version 19.0 [ 63.823] (II) RADEON(0): KMS Color Tiling: enabled [ 63.823] (II) RADEON(0): KMS Color Tiling 2D: enabled [ 63.823] (II) RADEON(0): KMS Pageflipping: enabled [ 63.823] (II) RADEON(0): SwapBuffers wait for vsync: enabled [ 63.828] (II) RADEON(0): Output DisplayPort-0 has no monitor section [ 63.890] (II) RADEON(0): Output HDMI-0 has no monitor section [ 63.896] (II) RADEON(0): EDID for output DisplayPort-0 [ 63.956] (II) RADEON(0): EDID for output HDMI-0 [ 63.956] (II) RADEON(0): Manufacturer: SAM Model: 771 Serial#: 1110590279 [ 63.957] (II) RADEON(0): Year: 2010 Week: 44 [ 63.957] (II) RADEON(0): EDID Version: 1.3 [ 63.957] (II) RADEON(0): Digital Display Input [ 63.957] (II) RADEON(0): Max Image Size [cm]: horiz.: 53 vert.: 30 [ 63.957] (II) RADEON(0): Gamma: 2.20 [ 63.957] (II) RADEON(0): DPMS capabilities: Off [ 63.957] (II) RADEON(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 [ 63.957] (II) RADEON(0): First detailed timing is preferred mode [ 63.957] (II) RADEON(0): redX: 0.649 redY: 0.338 greenX: 0.289 greenY: 0.609 [ 63.957] (II) RADEON(0): blueX: 0.146 blueY: 0.070 whiteX: 0.312 whiteY: 0.329

Xorg.1.log:

[code]II) LoadModule: “cirrus”
[ 3667.379] (II) Loading /usr/lib/xorg/modules/drivers/cirrus_drv.so
[ 3667.382] (II) Module cirrus: vendor=“X.Org Foundation”
[ 3667.382] compiled for 1.17.1, module version = 1.5.3
[ 3667.382] Module class: X.Org Video Driver
[ 3667.382] ABI class: X.Org Video Driver, version 19.0
[ 3667.382] (II) LoadModule: “savage”
[ 3667.382] (II) Loading /usr/lib/xorg/modules/drivers/savage_drv.so
[ 3667.384] (II) Module savage: vendor=“X.Org Foundation”
[ 3667.384] compiled for 1.17.1, module version = 2.3.8
[ 3667.384] Module class: X.Org Video Driver
[ 3667.384] ABI class: X.Org Video Driver, version 19.0
[ 3667.384] (II) LoadModule: “qxl”
[ 3667.384] (II) Loading /usr/lib/xorg/modules/drivers/qxl_drv.so
[ 3667.386] (II) Module qxl: vendor=“X.Org Foundation”
[ 3667.386] compiled for 1.17.2, module version = 0.1.4
[ 3667.386] Module class: X.Org Video Driver
[ 3667.386] ABI class: X.Org Video Driver, version 19.0
[ 3667.386] (II) LoadModule: “intel”
[ 3667.386] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 3667.390] (II) Module intel: vendor=“X.Org Foundation”
[ 3667.390] compiled for 1.17.2, module version = 2.99.917
[ 3667.390] Module class: X.Org Video Driver
[ 3667.390] ABI class: X.Org Video Driver, version 19.0
[ 3667.390] (II) LoadModule: “siliconmotion”
[ 3667.390] (II) Loading /usr/lib/xorg/modules/drivers/siliconmotion_drv.so
[ 3667.391] (II) Module siliconmotion: vendor=“X.Org Foundation”
[ 3667.391] compiled for 1.17.2, module version = 1.7.8
[ 3667.391] Module class: X.Org Video Driver
[ 3667.391] ABI class: X.Org Video Driver, version 19.0
[ 3667.391] (II) LoadModule: “openchrome”
[ 3667.391] (II) Loading /usr/lib/xorg/modules/drivers/openchrome_drv.so
[ 3667.394] (II) Module openchrome: vendor=“http://openchrome.org/
[ 3667.394] compiled for 1.17.1, module version = 0.3.3
[ 3667.394] Module class: X.Org Video Driver
[ 3667.394] ABI class: X.Org Video Driver, version 19.0
[ 3667.394] (II) LoadModule: “r128”
[ 3667.394] (II) Loading /usr/lib/xorg/modules/drivers/r128_drv.so
[ 3667.395] (II) Module r128: vendor=“X.Org Foundation”
[ 3667.396] compiled for 1.17.1, module version = 6.10.0
[ 3667.396] Module class: X.Org Video Driver
[ 3667.396] ABI class: X.Org Video Driver, version 19.0
[ 3667.396] (II) LoadModule: “tdfx”
[ 3667.396] (II) Loading /usr/lib/xorg/modules/drivers/tdfx_drv.so
[ 3667.397] (II) Module tdfx: vendor=“X.Org Foundation”
[ 3667.397] compiled for 1.17.1, module version = 1.4.6
[ 3667.397] Module class: X.Org Video Driver
[ 3667.397] ABI class: X.Org Video Driver, version 19.0
[ 3667.397] (II) LoadModule: “ati”
[ 3667.397] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[ 3667.397] (II) Module ati: vendor=“X.Org Foundation”
[ 3667.397] compiled for 1.17.2, module version = 7.6.99
[ 3667.397] Module class: X.Org Video Driver
[ 3667.397] ABI class: X.Org Video Driver, version 19.0
[ 3667.397] (II) LoadModule: “mach64”
[ 3667.397] (II) Loading /usr/lib/xorg/modules/drivers/mach64_drv.so
[ 3667.399] (II) Module mach64: vendor=“X.Org Foundation”
[ 3667.399] compiled for 1.17.1, module version = 6.9.5
[ 3667.399] Module class: X.Org Video Driver
[ 3667.399] ABI class: X.Org Video Driver, version 19.0
[ 3667.399] (II) LoadModule: “vmware”
[ 3667.399] (II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
[ 3667.433] (II) Module vmware: vendor=“X.Org Foundation”
[ 3667.434] compiled for 1.17.1, module version = 13.1.0
[ 3667.434] Module class: X.Org Video Driver
[ 3667.434] ABI class: X.Org Video Driver, version 19.0
[ 3667.434] (II) LoadModule: “nouveau”
[ 3667.434] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[ 3667.436] (II) Module nouveau: vendor=“X.Org Foundation”
[ 3667.436] compiled for 1.17.2, module version = 1.0.12
[ 3667.436] Module class: X.Org Video Driver
[ 3667.436] ABI class: X.Org Video Driver, version 19.0
[ 3667.436] (II) LoadModule: “mga”
[ 3667.436] (II) Loading /usr/lib/xorg/modules/drivers/mga_drv.so
[ 3667.438] (II) Module mga: vendor=“X.Org Foundation”
[ 3667.438] compiled for 1.17.1, module version = 1.6.4
[ 3667.438] Module class: X.Org Video Driver
[ 3667.438] ABI class: X.Org Video Driver, version 19.0
[ 3667.438] (II) LoadModule: “trident”
[ 3667.438] (II) Loading /usr/lib/xorg/modules/drivers/trident_drv.so
[ 3667.440] (II) Module trident: vendor=“X.Org Foundation”
[ 3667.440] compiled for 1.17.1, module version = 1.3.7
[ 3667.440] Module class: X.Org Video Driver
[ 3667.440] ABI class: X.Org Video Driver, version 19.0
[ 3667.440] (II) LoadModule: “neomagic”
[ 3667.440] (II) Loading /usr/lib/xorg/modules/drivers/neomagic_drv.so
[ 3667.441] (II) Module neomagic: vendor=“X.Org Foundation”
[ 3667.442] compiled for 1.17.1, module version = 1.2.9
[ 3667.442] Module class: X.Org Video Driver
[ 3667.442] ABI class: X.Org Video Driver, version 19.0
[ 3667.442] (II) LoadModule: “radeon”
[ 3667.442] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[ 3667.442] (II) Module radeon: vendor=“X.Org Foundation”
[ 3667.442] compiled for 1.17.2, module version = 7.6.99
[ 3667.442] Module class: X.Org Video Driver
[ 3667.442] ABI class: X.Org Video Driver, version 19.0
[ 3667.442] (II) LoadModule: “sisusb”
[ 3667.442] (II) Loading /usr/lib/xorg/modules/drivers/sisusb_drv.so
[ 3667.444] (II) Module sisusb: vendor=“X.Org Foundation”
[ 3667.444] compiled for 1.17.1, module version = 0.9.6
[ 3667.444] Module class: X.Org Video Driver
[ 3667.444] ABI class: X.Org Video Driver, version 19.0
[ 3667.444] (II) LoadModule: “vesa”
[ 3667.444] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 3667.444] (II) Module vesa: vendor=“X.Org Foundation”
[ 3667.444] compiled for 1.17.1, module version = 2.3.4
[ 3667.444] Module class: X.Org Video Driver
[ 3667.444] ABI class: X.Org Video Driver, version 19.0
[ 3667.444] (II) LoadModule: “fbdev”
[ 3667.445] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 3667.445] (II) Module fbdev: vendor=“X.Org Foundation”
[ 3667.445] compiled for 1.17.1, module version = 0.4.4
[ 3667.445] Module class: X.Org Video Driver
[ 3667.445] ABI class: X.Org Video Driver, version 19.0
[ 3667.445] (II) LoadModule: “modesetting”
[ 3667.445] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 3667.445] (II) Module modesetting: vendor=“X.Org Foundation”
[ 3667.445] compiled for 1.17.2, module version = 1.17.2
[ 3667.445] Module class: X.Org Video Driver
[ 3667.445] ABI class: X.Org Video Driver, version 19.0
[ 3667.445] (WW) Falling back to old probe method for cirrus
[ 3667.445] (II) Loading sub module “cirrus_laguna”
[ 3667.445] (II) LoadModule: “cirrus_laguna”
[ 3667.446] (II) Loading /usr/lib/xorg/modules/drivers/cirrus_laguna.so
[ 3667.447] (II) Module cirrus_laguna: vendor=“X.Org Foundation”
[ 3667.447] compiled for 1.17.1, module version = 1.0.0
[ 3667.447] ABI class: X.Org Video Driver, version 19.0
[ 3667.447] (II) Loading sub module “cirrus_alpine”
[ 3667.447] (II) LoadModule: “cirrus_alpine”
[ 3667.447] (II) Loading /usr/lib/xorg/modules/drivers/cirrus_alpine.so
[ 3667.448] (II) Module cirrus_alpine: vendor=“X.Org Foundation”
[ 3667.449] compiled for 1.17.1, module version = 1.0.0
[ 3667.449] ABI class: X.Org Video Driver, version 19.0
[ 3667.449] (WW) Falling back to old probe method for siliconmotion
[ 3667.449] (WW) Falling back to old probe method for trident
[ 3667.449] (WW) Falling back to old probe method for neomagic
[ 3667.449] (II) [KMS] Kernel modesetting enabled.

[ 3667.460] (WW) Falling back to old probe method for sisusb

[ 3667.460] (WW) Falling back to old probe method for vesa
[ 3667.460] (WW) Falling back to old probe method for fbdev
[ 3667.460] (WW) Falling back to old probe method for modesetting
[ 3667.460] No devices to configure. Configuration failed.[/code]

It looks like xorg is not detecting, loading or configuring your drivers properly.

May I ask how you updated the kernel to 4.5 and to a development version of Mesa?
Netrunner 17 comes with the 4.2 kernel and the last release of mesa was 11.1.2: http://www.mesa3d.org/

Is there anything else that have you updated outside of the official repositories?

I have simply the new kernel on the console updated e.g. (http://ubuntuhandbook.org/index.php/2016/03/upgrade-linux-kernel-4-5-ubuntu/)

and the Mesa driver I have a PPA= http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu

but when I look at the gpu stats about Google Chrome, Mesa is detected 11.3 and above also runs the GPU or hardware acceleration

It’s kid of hard to track issue when using unsupported packages, especially mesa.
Mesa can cause these kinds of issues since it is what provides the ddr drivers for xorg.

google chrome gpu log:

Version Information Data exported 20.3.2016, 22:38:55 Chrome version Chrome/49.0.2623.87 Operating system Linux 4.5.0-040500-generic Software rendering list version 0 Driver bug list version 8.46 ANGLE commit id 83aec70b3d94 2D graphics backend Skia Command Line Args --window-depth=24 --flag-switches-begin --disable-smooth-scrolling --enable-gpu-rasterization --ignore-gpu-blacklist --flag-switches-end Driver Information Initialization time 114 In-process GPU false Sandboxed false GPU0 VENDOR = 0x1002, DEVICE= 0x9908 Optimus false AMD switchable false Driver vendor Mesa Driver version 11.3.0 Driver date Pixel shader version 1.30 Vertex shader version 1.30 Max. MSAA samples 8 Machine model name Machine model version GL_VENDOR X.Org GL_RENDERER Gallium 0.4 on AMD ARUBA (DRM 2.43.0, LLVM 3.8.0) GL_VERSION 3.0 Mesa 11.3.0-devel (git-7d98bfe 2016-03-20 wily-oibaf-ppa)

that problem is, if I reinstall Netrunner 17 without PPA etc. then I have exactly the same problems, either start from the console or even only strokes on the screen and then nothing more, and that happens when SSDM updated we on version 0.13

OK, but that doesn’t help fix sddm and xorg not loading and/or crashing on startup.
I also noticed that xorg is loaded on tty7, the default for both sddm and systemd would be for xorg to start on tty1.
Did you change anything in your sddm.conf file to start it on tty7 instead?

I would suggest rolling back mesa to the official version and see if that helps.
I can’t see where the kernel update would have caused this unless there is a regression with it and radeon. I’ll do some research on this in the mean time.

No in sddm.conf I have not changed, everything left as it ever was.

what is but I am surprised that there were not these problems under Ubuntu / Ubuntu Mate

Ubuntu mate wouldn’t be using sddm nor would ubuntu.
Also did you also update the kernel and mesa in the same way when running ubuntu or ubuntu mate as well?

Yes, I have, on both systems, Mate and Ubuntu, Kernel and Mesa updated … and Xorg.con, everything available …

the only question is, what do I do?

Have you tried this combo out on Kubuntu yet?
Personally, I think that a configuration file is missing, corrupt or just not right compared to your other installs.
I’ve also seen mesa cause plasma-shell to crash xorg in the past, but that was an issue in the Intel driver.
Still I tend to not rule anything out.