back to Netrunner | back to Blue Systems

Canon MF4770 n ImageCLASS NO DRIVER?


Hello, I just purchased this Canon ImageCLASS MF4770 n and I cannot find a driver for it.
I like the printer and want it to work.

It is a laser jet all in one printer.

I don’t really care about faxing anything, but I do need the printer and scanner to work.

Please let me know if there is a way to get this working… maybe another existing
driver will work??



Hey thanks for your input! But I should say that in the instructions it says,

Step 3: choose a browser, open a browser window and type http://localhost:631 in the address bar. Then you will see the CUPS graphical interface in your browser.

After adding this to Firefox and submitting, I get an information window for cups, but nothing about adding a new printer. So, the only thing I can think of is to call Canon tomorrow and see if they will guide me through the process.

My Rant:
Its really something that most of the manufacturers STILL haven’t really caught on to the growth of Linux!
There should be a program to simply install for the end user. I’ve got better things to do than to have to sit and work on my OS all the time.


“I get an information window for cups, but nothing about adding a new printer”

It’s under the Administration tab, but here is a quick shortcut for you: http://localhost:631/admin

“There should be a program to simply install for the end user.”

There are quite a few printer configuration utilities actually, but for your purposes Netrunner (being a KDE based distro) has a utility already installed by default, it’s in KDE’s System Settings (Control Center) and called simply Printers.

Menu > Settings > System Settings


Well, I called Canon today for support and all they could tell me is they don’t support Linux.
These companies NEED to start supporting Linux as it growing FAST!! Everyone I know
now has converted over to either Netrunner or Zorin.

PEOPLE: We need to call these companies whether they support Linux or Not And
express our concerns!! When they say they don’t support Linux… YOU say… well,
then I am forced to return your printer to the store!! Thank You… GOODBYE!!
(and then hang up before they can say anything else. If we all do this… I can almost
guarantee they will be looking into supporting Linux. DO IT!!

Now I need to figure out how to get this running or back to the store and I will buy a
BROTHER who DOES support Linux. Only issue is… I will have to spend $200 more. 8/


Best printers for Linux are HP, they even have their own GUI tools.


Thanks, but I hate HP! Too many issues and they try to control you
by using their printers. Plus, they only give starter cartridges and
make you spend BuuKuu bucks on new cartridges! Then their
cartridges cost more than the printer. They’re like drug dealers!
They get you in thinking their printer is cheap and once your in, the
price goes way up!!

AND… if you don’t spend at LEAST $350 on a printer, you will be
lucky to get a year out your cheap printer… unless of course you
don’t use it much.

I bought a $200 Hp a year and a half ago and have had numerous
issues with it and finally took it out back and SMASHED it with my
trusty ole sledge hammer!! I was thinking of mailing the pieces to HP.


OK, sorry. I didn’t mean to pour salt into a wound. let me now help you out:

When you go to http://localhost:631/ there are tabs along the top of the page, the one you need is Administration, you can add printers from there, Here is a short cut for you: http://localhost:631/admin

You can also use one of these great GUI utilities to manage printers/cups:

system-config-printer (GTK2 based)
Menu > Settings > Print Settings

kdeutils-print-manager (QT/KDE based)
Menu > Settings > System Settings > Printer


It’s asking for user ID and password
What do I put there? I tried computer
ID and pass, but that didn’t take.


user name: yours
password: yours


Ok… I did that before and it didn’t take. Maybe I erred and didn’t realize it.
But I got in this time. Now it’s asking for a Location. How do I know this?
Sorry, not a techie guru. I know some things, but not this.

EDIT: Hey, I just typed ‘printer 1’ in the location field. I added the file from
the Debian 64 folder and the printer will not print. Says Failed. There were
two files in the Debian folder; one was ‘common’, but I tried both and
neither of them made my printer print. Did I do something wrong here?


Here is what it says after adding so-called drivers: (doesn’t matter which driver I use, it fails)
Driver One: cndrvcups-common_2.90-1_amd64.deb
Driver Two: cndrvcups-ufr2-us_2.90-1_amd64.deb

Canon_MF4700_Series (Idle, Accepting Jobs, Not Shared, Not Color-Managed)
Description: Canon MF4700 Series
Location: Print1
Driver: Local System V Printer (grayscale)
Connection: usb://Canon/MF4700%20Series?serial=0145F24CBFED&interface=1
Defaults: job-sheets=none, none media=unknown

Search in Canon_MF4700_Series:

Showing 1 of 1 active job.
▼ ID ▼ Name User Size Pages State Control
Canon_MF4700_Series-8 Unknown Withheld 1k Unknown stopped
“Filter failed”


Please don’t take this the wrong way, but are you completely new to Linux?
.deb files are Debian Package Manager files, these are what Netrunner Standard (Ubuntu.Debian) use to install software. You will need to be double click on those files to install the drivers onto your system.


I tried that as well. It said there were missing dependencies.

EDIT: I got it to install now… I guess they need to be installed in a certain order.
I’ve been on Linux for 2 years, but I have had an HP printer and as far as
installing anything… I have always used synaptic. Most everything I do is
online and didn’t know about .deb until now.

How do I remove drivers from the list?

Thanks for your help!


What list? Please, attach a screen shot.


The printer list where you go to add a printer.


Do you have more than one printer installed (wrong drivers), or are you talking about after you hit add printer?
If you mean after you hit the add printer button then there is no need as they take hardly any room and are part of the cups package. Now, if you mean your failed attempt’s at adding your printer (ie wrong driver) then just right click each of them to remove the extra ones.


No I tried adding the 32bit drivers when I couldn’t get the 64bit ones to work. So now I wanted to remove them. But if they take little space… no big deal, I guess.


Oh, OK, to uninstall you should be able to just double click them again and select remove/uninstall them from there.


Thanks for your help on this!~