clamtk help [solved]

New thread ok…sorry about that. I didnt know about hijacking a solved thread. :blush:

I cannot get clamtk running. It spins and then disappears.

[quote][dakota@dakota ~]$ clamtk
Icon ‘gtk-new’ not present in theme at /usr/lib/perl5/vendor_perl/ClamTk/ line 262.
[dakota@dakota ~]$ [/quote]
Is this why?

Or what do I need to do to get the info you need to help me.
And ‘yes’ we will be downloading on the linux box and taking things over to a windows machine.
Household of 8 people using whichever pc is available at the time.

Did you install clamtk from the AUR?

If not then remove whatever you did and run:

yaourt -S clamtk

I just installed it on my machine, here is a screen shot:
There is also quite a few commercial antivirus software in the AUR as well.

Yes that is what I did…
yaourt -S clamtk

Strange, it’s working here.
I used octopi to install it, but that shouldn’t make a difference.
Did you allow yaourt to build perl-text-csv as well as clamtk?

You might want to check all of the dependencies?
perl-libwww perl-http-message
perl-text-csv perl-json

I do not know how to do any of that.
The previous thread the suggestion was to say no to edit and yes to build/install…
I do not understand that because every step in terminal had the word edit in it.

Which is why I need a step by step for dummies.

And in octopi…clamav is on the list but if I search clamtk I get zero results

It seems like clamtk wasn’t completely installed or at least it searches for a missing icon.
In my opinion however I would recommend not to install any of the antivirus options on the Linux box but just use antivirus on the windows boxes.

That is because in octopi you have to click on in the right hand section to search the AUR.

I agree with leszek on this one, there is really no need to run antivirus on your Linux machines, unless your sharing files with other windows users and your not completely sure of their security practices.

ok thank you…found it in there…first question in terminal is this…

Edit PKGBUILD ? [Y/n] (“A” to abort)

and every question down the line has the word edit in it.
so basically I do not know how to follow it down through the install.

Enter n

Yes, enter n for the ones that say edit and y for everything else.

I’m not sure if this is going to effect anything, but did you install all of the base-devel packages first?

sudo pacman -S base-devel

hit enter to select all and enter again to install.

doing the base-devel
and for this part Yes, enter n for the ones that say edit and y for everything else.

They all say edit…that my problem.

Yes to this part…

I’m sorry, but that is impossible, I’ve been running Arch, Manjaro and now Netrunner Rolling for a very long time and NEVER ever had that happen, you must be reading them wrong.

Typical AUR install with yaourt:
First, yaourt will ask if you wish to edit the pkgbuild and/or the xx.install files, on these prompts you would enter n.
Next, it will ask if you wish to continue building, this is where you enter y.
Now yaourt will download and/or extract the files, it may need to compile from the source code at this point, this can sometimes take a while.
Then it will create a package file for use with pacman,
And finally, you will be asked if you wish to continue to install the newly created package, this would also be a y.

Ok it was no to the first 2 and yes to the rest. still nothing…
I am right back to this…
Icon ‘gtk-new’ not present in theme at /usr/lib/perl5/vendor_perl/ClamTk/ line 262.

I googled this and I am not the only one.
I still have not founbd the answer for my netrunner.

Ah, never-mind your having a gtk theme issue, sorry…

What do you have set under System Settings > Desktop Appearance > GTK


I am making progress, i think…
from what I am reading here

Clamtk is not working with Oxygen theme.
Which mus the default theme from installation as I have never changed any of those settings.

Actually your having an issue with the GTK icon setting not the theme itself.
Have you updated your system after install?
There have been a few important updates since the ISO was released.
If not you may need to use the command line to update your system.

yes fully updated

Have you rebooted since you last updated the system?

Reboot yes…

I tried what it says here
and clamtk works now…

That is great…only I hate those icons.
Thank everyone. I wouldn’t care but I have 4 teenagers that
have horrible habits and I am only one Mom, I cant be there every second and tell them
to make sure to scan this and scan that. You know what I mean?
And my 9 year old is even worse…

I don’t think you actually needed that script, since I never did that and it works fine here.

Question, what comes up as Installed (green) in octopi if you type in GTK?