Correct way to upgrade Plasma


So what is the correct way to upgrade the Plasma to 5.10? I have currently Debian Stable in my repos, so Stretch. Is it possible to upgrade the Plasma with Stretch? Or do I have to switch to some Testing snapshot?

Just enable the disabled repositories and upgrade :slight_smile:

Though I believe there’s a outstanding issue with qtvirtualkeyboard that can be worked around by using the force-overwrite option.

I’m curious which install version you started with. I think Netrunner Desktop 17.06 comes with Plasma 5.10 out of the box.

I’m also curious to learn how your upgrade goes.


OK, so I will enable the backport repos and just install what it gives me :slight_smile: I started with Netrunner 17.03 and when Debian Stretch came out, I switched to it, to have the stable system until initial Testing mumbo-jumbo settles (at least the first half a year I would say :)) Keep the fingers crossed for me since it’s an office workstation :wink:


So I triggered the upgrade of Plasma, but the first thing I noticed was that it wanted to remove packages plasma-desktop and netrunner-desktop, which is not correct I think. So, please, how should I proceed? This upgrade must run correctly! These are my current sources:

deb stretch main non-free contrib deb netrunner-backports qt5 plasmazilla plasma netrunner netrunner-desktop kde-applications frameworks extras ds9-common ds9-artwork calamares backports deb netrunner-1703 backports calamares ds9-artwork ds9-common extras frameworks kde-applications netrunner-desktop netrunner plasma plasmazilla qt5

I repeat this is an upgrade from Netrunner installation 17.03.

Thank you very much.

Please change the following line

deb stretch main non-free contrib


deb testing main non-free contrib

Because Netrunner backports depends on the debian testing release

Yes but in the other thread, the people who did it that way ended up with no desktop at all and had to revert a lot of stuff back using some specific snapshot… have your already fixed this?

Bad advice shadeslayer, I just changed to testing and ended up with no desktop.
The current testing repo is NOT working with netrunner.

This is the kind of thing that makes people lose faith in the distro. :frowning:

Wouldn’t the safest approach be to use the snapshot from Netrunner 17.06? When I now switch from stretch to testing it gets hundreds of new packages, not just Plasma related. This is all the stuff Debian pulled in for Buster, but it’s all very unstable at this point and will be that way minimum for half a year. So I really wouldn’t like to break my office workstation with all that stuff. I just want to upgrade the Plasma part…

Just like stated in the other thread this has been fixed now.
It should be save to upgrade again.

If you know your way around debian based distros this is possible pretty easy. You don’t have to upgrade all packages from testing. You just need to activate the testing repo to upgrade plasma-desktop (apt-get install plasma-desktop) and it should only pull in the packages it needs for updating. After that you can disable the testing repo. Though I would recommend disabling the backports aswell then.

OK leszek, I’ll try it in the afternoon, hopefully it’ll work fine. I put my trust in you :wink: I ran Debian as my main distro for a few years, so it shouldn’t be a problem with getting around it, but I know that mixing various Debian releases was never a good thing, so I’ll just upgrade Plasma and leave it that way. I’ll upgrade the other components a few months later, when Buster is more stable…

Yep, I should have known better not to upgrade all the packages to the latest testing, I had no problems upgrading to the 20170725 snapshot (except the qtvirtualkeyboard bug previously discussed in the another thread).

My question is when and how do I know what repos (snapshot?) to use when upgrading since the latest testing will break stuff.

Does it still break for you?
It shoudln’t and if its breaking do you have some logs to tell us what is breaking?

In theory will the following repos cause any trouble in a clean install? netrunner-1706 backports calamares ds9-artwork ds9-common extras frameworks kde-applications netrunner-desktop netrunner plasma plasmazilla qt5 testing main non-free contrib

I did a simulation and got the following log (not very helpful, at least for me).

Is it possible to upgrade and test it in the live distro? I really don’t want to break my desktop again.

Edit - Just found something odd in the log:

“The following packages were automatically installed and are no longer required:

netrunner-desktop-settings netrunner-desktop-settings-desktop
netrunner-settings-autostart netrunner-settings-firefox
netrunner-settings-grub netrunner-settings-kcmabout
netrunner-settings-python-apt netrunner-settings-sddm

This is just the way I’ve done it and how managed the latest plasma upgrade : I’m on stretch + backports + netrunner-backports. I’ve enabled the sid repositories just to upgrade to the newer plasma since i saw the new qt 5.9 dependency and then switched back to stretch. Is that way correct ?

Hi leszek,

Well no luck with the upgrade. I did exactly as you said, but after the reboot the system just failed to start the graphics, giving me just terminal. I’ve tried your commands from the other post with the snapshot and downgrading, but that doesn’t work either. It says that 3 packages have unmet dependencies: kde-style-qtcurve-qt5, libkf5declarative5 and python-pyqt5 - it says that it depends on 5.9.1 but version 5.7.1 is to be installed.

So all in all, the upgrade failed and I’m really lucky that I have an old installation of Maui on the other partition. The sources I tried the upgrade with are standard testing as you said and 1703 backports. No luck… Is there anything that can be done?

Yes the plasma upgrade “is fixed”/upgrades without removal. I continue find a hiccup with qml-module-qtquick-virtualkeyboard.

I created a vm and did several dist-upgrades. The smoothest I’ve found so far is this:

apt-get -d dist-upgrade ## download without install
sudo dpkg -i --force-overwrite /var/cache/apt/archives/qml-module-qtquick-virtualkeyboard_5.9.1+dfsg-3_amd64.deb ## force the circular dependency
sudo apt-get --fix-broken dist-upgrade ## unpack, configure

I’m gonna roll back and do only the plasma now.

In a vm I installed 1703.
I dist-upgraded to stable & stable-updates
I enabled debian testing & netrunner-backports
I installed plasma-desktop (upgrade to 5.10)
(I resolved that pesky qtvirtualkeyboard, finished install)
I went back to stable & removed netrunner-backports

Everything seems fine. Maybe this is the path you seek?

I’m not going back to the office until Tuesday, so when I get there, I’ll try it. Hopefully it’ll work…

I do the -d download without install to make the virtual keyboard fix happen fast, it just feels better.

I’ve done this at least 6 times now. Let me know what happens.