Flash plugin not working on all sites


Having issues with this particular http://www.tv3play.ee and some other sites.

It just refuses to play the flash content. It even does not start to do so. Kind of like when a plugin does exist but it does not work.

Discovered that Linux Mint 17 KDE x64 does not have this issue. The flash plugin version is the same though!


I tried even to delete the .mozilla profile folder and use a fresh untoutched Firefox without 3rd party plugins.
That did not help.

Hello. Is this a one time occurence ?

Really would like to fully use Firefox :frowning:

It is really a hard to fix issue for us. Firtsly no one here uses tv3play.ee . Secondly FlashPlayer is proprietary software by adobe and adobe does not suport it anymore (besides security fixes).
It is strange however that it is running on another distribution which ships the same version.
Do you have the same graphics drivers installed ? Do you even use the official nvidia or ati/amd drivers ?

The only other solution coming into my mind is trying chrome as google ships its own flashplayer version with it.

Tried it with Google Chrome. No luck.
Using the open source driver on Intel HD 4000 CPU integrated graphics.
Meaning I don’t use a proprietary driver.

Whats the particular problem with google chrome ? Does it crash or isn’t the website detecting that flash is installed? Did you try other flash sites to confirm it isn’t a website issue

It just uses the spinning wheel for a second. Then gives me only a black screen instead of showing the flash content.
Goes for both versions of flash. Either the Google Chrome or the Firefox one.

Both about:plugins show that flash is there.

On both it does not show a crashed Flash text.

So then I assume its an issue with that particular website as other websites like this one are running fine ?

Yes, other websites seem to run.
It’s strange never the less. Because of this I can’t use Netrunner for other people. Too bad.

And yes. Flash test shows correctly.

Found the probable cause.

The modification you made for Firefox to start with the system messes up Flash also.
Particularry when one unticks the script. So it won’t start with the system. Which is a workaround for various other messes as I understand from reading in the netrunner forums.

I booted Netrunner 14 Frontier in Virtualbox. Both the 32 and 64 bit ones did show www.tv3play.ee when I did not turn off the autorun script that starts Firefox in the backround when 2GB and more RAM are present.

That’s when I ran Netrunner as Live DVD’s in VirtualBox. Going to install both 32 and 64 bit Frontier version in virtualbox also to see if an installed environment acts the same.

I can confirm that doing a fresh install of both the 32 bit and the 64 bit Netrunner 14 Frontier versions in Virtualbox have the same indentical reaction.

When leaving the script to start at startup everything works.
And unticking the script does not affect it also.

Could there be some other reason ? Can some additional packages interfere with the open source intel driver which comes with the sytem preinstalled?

http://www.tv3play.ee/ this site requires the same kind of DRM code as Netflix, Adobe flash player under Linux does not have this code.
You will need to use the same HTML5 work around as described here:

I tried a non Ubuntu based distro like Manjaro 8.10 XFCE x64.
Also works fine out of the box.
None of those other distros have such speacial stuff installed for it to work.
Nor is there anything special installed in the drivers compartment.

Seems like a mystery :slight_smile:

Well I’m running Netrunner Rolling (Manjaro) with google-chrome and it didn’t seem to work for me either. Never mind. it’s working, the first video I tried had an error message, so I tried another video and it worked. Maybe only some of the videos are DRM’d?

Did you install the Kubuntu restricted extras?

You may need all of gstreamer 0.10 including all the bad and ugly plugins as well or even gstreamer 1.x, Manjaro installs both gstreamer 0.10 and 1.4 by default.

I tried several shows. All do work under Manjaro.
Loged back into Netrunner 14 Frontier. And trying several different shows from the site.
Still only the black screen instead of a Flash feed.

Did you install the Kubuntu restricted extras?

Actually I didn’t. Linux Mint 17 KDE x64 doesn’t have it either. But never the less, it works.

That’s what I thought, Flash uses the gstreamer and other native codecs on Linux for playback. On Ubuntu no patented codecs are installed by default, the restricted formats meta package installs all the codecs needed including those with patent issues. Linux Mint, Manjaro, etc. just happened to already have the codecs required by those videos installed already.

So there is a solution?

Yes, please reread my previous post, I was still editing it when you quoted me.

You can either hunt down the codec you need to install manually or just install the restricted extras meta package.

Though the kubuntu-restricted-extra-codecs package and its codecs are installed already under Netrunner.
Also flashplayer normally brings its own decoding library and is not using gstreamer (that would be more awesome in terms of SSE2 problems and VAAPI support)