back to Netrunner | back to Blue Systems

Installation issue on Lenovo Thinkpad E595 - kernel too old? [SOLVED]

Hi. We recently bought the above laptop after confirming people were installing linux on this model. As we use Netrunner, the next step was to install NR20.01 for dual boot. The installation issue identical to Installation media booting only to CLI however occurred.
I’ve since found an installation guide elsewhere agreeing with the above suggesting that the buster kernel does not support all of this hardware. The post author succeeded by installing buster CLI only, upgrading to bullseye then installing the UI.
I have tried live kubuntu 20.04 as a test and it launched successfully.

Options seem to be to:

  1. switch to kubuntu or similar or debian bullseye through buster as the intermediate at least till Debian stable catches up to allow NR to be installed
  2. try to build a live NR 20 using bullseye (never done anything like this though).

For option 2, reading suggests there are tools that would allow me to install NR20.01 to a virtual machine, switch to bullseye sources & update then create a live installation iso. What I cannot work out is how to install this new iso onto another machine.

So the primary question is - is option 2 a lot harder then the articles suggest and if a possibility, how can the new iso be installed?

FYI, fast startup was deactivated in Win10. I tried with and without Secure Boot disabled and with legacy boot only. The NR live version actually ran in legacy mode and performed an installation (grub written to “/” just to be safe) but the laptop does not see any operating system present at all on reboot.

Yes the linux kernel debian provides and we ship in Netrunner is too old for this hardware.
I have the same laptop and installed KDE Neon on it.

You could try out Neptune (a distro done by me personally) that in its version 6.5 ships with the Debian Buster Backports Kernel which should get you going. Though I suggest installing a newer kernel anyway as otherwise the radeon card can ocassionally freeze on Xorg. (ubuntu has precompiled vanilla kernels that work on debian aswell)
If you really want Netrunner now. You could install Neptune as it is using the same base and add the Netrunner sources and install the netrunner-desktop package.But maybe you just stick with Neptunes defaults :slight_smile:

With much thanks, leszek. :+1:

Neptune installation was smooth and I eventually rebooted into grub after I deactivated Fast boot from Win 10 and Secure Boot in bios.

Both Neptune & Win 10 (my wife needs it occasionally) run fine.

[Solved - but I can’t seem to be able to edit my first post - no edit option at the bottom - something obvious I’m missing?]

Great that it works. I edited the title and added solved.