back to Netrunner | back to Blue Systems

Installation media booting only to CLI


#1

Hello there,
I’m trying to install Netrunner on my Tuxedo laptop with Intel Comet Lake chipset.
This is the hardware as reported when booting it with a Manjaro live usb:

[manjaro@manjaro ~]$ inxi -Fxzc0
System:
  Host: manjaro Kernel: 5.4.2-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: KDE Plasma 5.17.4 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: TUXEDO product: TUXEDO v: N/A serial: <filter> 
  Mobo: TUXEDO model: N141CU serial: <filter> UEFI: INSYDE v: 1.07.04 
  date: 08/30/2019 
Battery:
  ID-1: BAT0 charge: 36.6 Wh condition: 36.9/35.3 Wh (105%) 
  model: Notebook BAT status: Charging 
CPU:
  Topology: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: C L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 36812 
  Speed: 3602 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 3598 
  2: 3601 3: 3595 4: 3604 5: 3578 6: 3600 7: 3606 8: 3600 
Graphics:
  Device-1: Intel vendor: CLEVO/KAPOK driver: i915 v: kernel 
  bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.6 driver: intel unloaded: modesetting 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics (Comet Lake 3x8 GT2) 
  v: 4.5 Mesa 19.2.7 direct render: Yes 
Audio:
  Device-1: Intel vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.4.2-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: CLEVO/KAPOK driver: r8169 v: kernel port: 5000 bus ID: 3b:00.1 
  IF: enp59s0f1 state: down mac: <filter> 
  Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 5000 
  bus ID: 40:00.0 
  IF: wlp64s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 972.54 GiB used: 101.0 MiB (0.0%) 
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB 
  ID-2: /dev/sda type: USB model: General USB Flash Disk size: 14.92 GiB 
  ID-3: /dev/sdb type: USB vendor: PNY model: USB 2.0 FD size: 3.75 GiB 
Partition:
  ID-1: / size: 23.30 GiB used: 101.0 MiB (0.4%) fs: overlay 
  source: ERR-102 
Sensors:
  System Temperatures: cpu: 65.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 233 Uptime: N/A Memory: 31.07 GiB used: 672.4 MiB (2.1%) 
  Init: systemd Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 inxi: 3.0.37 

If I try to boot it with the current Netrunner 20 from live usb, I only get to the command line, it looks like this:

As you can see, starting X.org manually was unsuccessful.
I also tried the fix of adding the “vga=normal nomodeset” kernel parameter proposed in installation instructions, but it’s not working.

First I thought the installation media was maybe broken, but I tried it on my desktop pc and eveything’s fine there. As you can see in this thread on the Manjaro forum, Manjaro won’t run properly on this system either - I’ve only been successful with a Kubuntu version provided by the OEM so far.


#2

Seems like the graphics card has issues and might be too new. Though yeah it should boot with “vga=normal nomodeset”
If it doesn’t you might need a new linux kernel. Though that is not easy to do on a live system.

What about the Xorg.0.log in /var/log/? Does it have any error message that might be useful?


#3

There’s no Xorg.0.log file in /var/log.
I found sddm.log, but appears to be empty.
There’s also a kernel log that looks useful, I’ve pasted it here:


But I don’t know what exactly to query for in here… any suggestions?


#4

Xorg.0.log should be now under ~/.local/share/xorg/Xorg.0.log so in your home directory.

The link to the kernel log is not working for me.


#5

nope, it’s not in here either. /home/live/.local/share contains only 2 directories: dolphin and keyrings, no xorg folder
I had the kernel log pasted to hastebin, but apparently they are having problems, so I replaced i t with a paste on rentry.co. Is that still not working?


#6

I now tried to boot a live usb with vanilla Debian(KDE) on the same laptop, and this went the same way, with the boot process ending at command line. However, I did find Xorg.0.log here:

[    38.509] 
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[    38.509] Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
[    38.509] Current Operating System: Linux debian 4.19.0-8-amd64 #1 SMP Debian 4.19.98-1 (2020-01-26) x86_64
[    38.509] Kernel command line: BOOT_IMAGE=/live/vmlinuz-4.19.0-8-amd64 boot=live components locales=de_DE.UTF-8 quiet splash findiso=
[    38.509] Build Date: 05 March 2019  08:11:12PM
[    38.509] xorg-server 2:1.20.4-1 (https://www.debian.org/support) 
[    38.509] Current version of pixman: 0.36.0
[    38.509] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    38.509] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    38.509] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar 31 12:03:10 2020
[    38.511] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    38.516] (==) No Layout section.  Using the first Screen section.
[    38.516] (==) No screen section available. Using defaults.
[    38.516] (**) |-->Screen "Default Screen Section" (0)
[    38.516] (**) |   |-->Monitor "<default monitor>"
[    38.516] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    38.516] (==) Automatically adding devices
[    38.516] (==) Automatically enabling devices
[    38.516] (==) Automatically adding GPU devices
[    38.516] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    38.516] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    38.516] 	Entry deleted from font path.
[    38.516] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins
[    38.516] (==) ModulePath set to "/usr/lib/xorg/modules"
[    38.516] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    38.516] (II) Loader magic: 0x55a59c60fe20
[    38.516] (II) Module ABI versions:
[    38.516] 	X.Org ANSI C Emulation: 0.4
[    38.516] 	X.Org Video Driver: 24.0
[    38.516] 	X.Org XInput driver : 24.1
[    38.516] 	X.Org Server Extension : 10.0
[    38.516] (++) using VT number 1

[    38.518] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[    38.519] (--) PCI:*(0@0:2:0) 8086:9b41:1558:1403 rev 2, Mem @ 0x6025000000/16777216, 0x4000000000/268435456, I/O @ 0x00006000/64, BIOS @ 0x????????/131072
[    38.519] (II) LoadModule: "glx"
[    38.520] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    38.553] (II) Module glx: vendor="X.Org Foundation"
[    38.553] 	compiled for 1.20.4, module version = 1.0.0
[    38.553] 	ABI class: X.Org Server Extension, version 10.0
[    38.553] (==) Matched modesetting as autoconfigured driver 0
[    38.553] (==) Matched fbdev as autoconfigured driver 1
[    38.553] (==) Matched vesa as autoconfigured driver 2
[    38.553] (==) Assigned the driver to the xf86ConfigLayout
[    38.553] (II) LoadModule: "modesetting"
[    38.553] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    38.557] (II) Module modesetting: vendor="X.Org Foundation"
[    38.557] 	compiled for 1.20.4, module version = 1.20.4
[    38.557] 	Module class: X.Org Video Driver
[    38.557] 	ABI class: X.Org Video Driver, version 24.0
[    38.557] (II) LoadModule: "fbdev"
[    38.557] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    38.558] (II) Module fbdev: vendor="X.Org Foundation"
[    38.558] 	compiled for 1.20.0, module version = 0.5.0
[    38.558] 	Module class: X.Org Video Driver
[    38.558] 	ABI class: X.Org Video Driver, version 24.0
[    38.558] (II) LoadModule: "vesa"
[    38.558] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    38.562] (II) Module vesa: vendor="X.Org Foundation"
[    38.562] 	compiled for 1.20.1, module version = 2.4.0
[    38.562] 	Module class: X.Org Video Driver
[    38.562] 	ABI class: X.Org Video Driver, version 24.0
[    38.562] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    38.562] (II) FBDEV: driver for framebuffer: fbdev
[    38.562] (II) VESA: driver for VESA chipsets: vesa
[    38.562] (EE) open /dev/dri/card0: No such file or directory
[    38.562] (WW) Falling back to old probe method for modesetting
[    38.562] (EE) open /dev/dri/card0: No such file or directory
[    38.562] (II) Loading sub module "fbdevhw"
[    38.562] (II) LoadModule: "fbdevhw"
[    38.562] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    38.565] (II) Module fbdevhw: vendor="X.Org Foundation"
[    38.565] 	compiled for 1.20.4, module version = 0.0.2
[    38.565] 	ABI class: X.Org Video Driver, version 24.0
[    38.565] (EE) Unable to find a valid framebuffer device
[    38.565] (WW) Falling back to old probe method for fbdev
[    38.565] (II) Loading sub module "fbdevhw"
[    38.565] (II) LoadModule: "fbdevhw"
[    38.565] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    38.565] (II) Module fbdevhw: vendor="X.Org Foundation"
[    38.565] 	compiled for 1.20.4, module version = 0.0.2
[    38.565] 	ABI class: X.Org Video Driver, version 24.0
[    38.565] (II) FBDEV(2): using default device
[    38.565] (EE) Screen 0 deleted because of no matching config section.
[    38.565] (II) UnloadModule: "modesetting"
[    38.565] (EE) Screen 0 deleted because of no matching config section.
[    38.565] (II) UnloadModule: "fbdev"
[    38.565] (II) UnloadSubModule: "fbdevhw"
[    38.565] (EE) 
Fatal server error:
[    38.565] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[    38.565] (EE) 
[    38.565] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    38.565] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    38.565] (EE) 
[    38.568] (EE) Server terminated with error (1). Closing log file.

I don’t know how to read these log files, I hope someone here can make sense of it (keep in mind though that the above is vanilla Debian, not Netrunner).

Under Manjaro, this laptop does boot to Plasma Shell, but it also has graphics issues making it pretty much unusable.
Over there, it has been suggested that
a) using Wayland instead of X or
b) using the modesetting driver,
or both, might help, but I haven’t tried either in Manjaro, because I lack the knowledge to understand how it is done.


#7

Comet lake if fairly new and support is still being added with every kernel release.
For exammple, power management support for the comet lake was just added to the RAPL Driver in the 5.5 kernel tree this last November.
https://www.phoronix.com/scan.php?page=news_item&px=Linux-5.5-Power-Management

You already asked these questions on the manjaro forum.

The Comet lake requires at minimum for any kind of support the 5.2 series of kernel.
Personally, I would suggest that you start with the 5.5 kernel series.


#8

Is it possible to install directly form an official ISO with a different kernel?


#9

Possible yes but you need to rebuild the Live ISO then.
If you have no experience to rebuild the ISO I would not recommend it.