Muon Software updater etc.

I like the general layout and design of this distro. It looks great it’s fast and it’s different than all the vanilla KDE suites.
I do have some questions with software?

I download the latest 32 bit release and it needed update’s so I let Moun updater do it’s thing and install the updates. About 20 minutes later it asked for a restart. Okay, After that restart I noticed Muon uninstalled all of the Muon software? Why? And it didn’t just it take it out of the menu because doing a full search for muon returned no files found? And the update also broke apt-url so Jack n Joe software online didn’t work either. I had to go to Synaptic and install all The Muon packages and apt-url to be back where I was before the update.

I reinstalled the distro a second time from scratch and then tried sudo apt get update / upgrade without Muon figuring Muon might be the problem but this updated only portions of the software and then muon still popped up with items needing updates after a reboot. So is this normal because doing an command line sudo apt get update should install all updates needed correct ? Without muon? I’m confused here.

Yes this is a issue facing normal Kubuntu too, for some reason it removes muon when you update KDE.
An updater issue methinks.
You could re install muon using synaptic or something, its a good thing too as both command line and synaptic are both good backups.

Actually I was running Kubuntu 12.04.1 LTS and this wasn’t an issue in Kubuntu? It never uninstalled Muon or anything else unintentionally or by accident. Seems like updates in the distro breaks things.

Yes but did you use the KDE backports PPA?

Actually never paid close attention to the software sources.
It’s still confusing for an average user to understand this once that disappears it frustrates users into distro hopping.


Well understood, but hey all distros have little quirks.
I understand the frustration but first hand experience is the only true way to learn.

On this sir you are correct. Although I had a few Distros actually behave.
Seriously though I like this distro and will stick with through the small tribulations.

Thanks for your help.

Sort of late response, but not uncommon here, I guess. I don’t know if it was a fluke, but I did the following and it worked much better than when I did all updates in one step. First in the Muon Updater, I installed just the security updates, then restarted. Then, I installed the updates not requiring changes or removal of packages, then restarted. Then I installed the rest that asked to be marked and restarted. Muon still intact. The Muon Suite as I call it is certainly a big part of what makes Netrunner better than most other Ubuntu derivatives. That going away… well, many of you noticed the difference using Synaptic to get the Muon apps back. Which ones do I install? Oh,no… Even if I have to abandon Netrunner, I will look for Muon on any distro I try.

I had updated (as it turned out to kde 4.10) as others after a clean install of 12.12.1 and had muon and other apps deleted from the installation. On my installation, startup disk creator, additional drivers, konversation and calligrflow were also removed. Did they remain with your approach?

Also, is the clock keeping the correct time? I also have the same issue as in

I’m wondering what other problems now exist in the installation and should I reinstall or hope a timely fix arrives. Has anybody else tried BrtrdSlag’s approach?

I used Muon Update Manager (Software Updates). I don’t know what was being updated, only what steps I took to do it. It was 12.12.1 64bit install from Live USB though. The items you mention are still there. I did notice the following though. The System Monitor was replaced with KSysGuard (System Monitor). I think the taskbar tray icons for Battery Monitor and KOrganizer Reminder Daemon disappeared, but I may have just removed them myself; can’t remember (I don’t use them). The big difference though (which, based on all other Ubuntu derivatives I tried, is expected) was that VLC and other similar apps stopped recognizing Windows shares properly after the updates (I think the last round). My fix was to go to Muon Software Center and look for SMB4k and install. Then I made a startup entry for it (System Settings, Startup & Shutdown, Autostart, Add Program) and now it loads at startup and restores my bookmarked shares (per settings changes). This would be required whether I used Ubuntu, Kbuntu, Mint…

Here’s where I found a fix for the time problem (I believe it was already a problem before the updates though).

Still can’t figure out what caused that but it was there through a few installs before I tried fixing, not likely caused by Netrunner in my case. If that’s the wrong fix, let me know, and I’ll dig through the history again and find another page.
Here are the others, I can’t remember which one is right at this point.

I tried the sequential update of BrtrdSlag and several variations. The security updates went fine but as soon as I tried any system update while ignoring updates that would add or remove programs I was getting a “white screen of death” on the next reboot when I would expect the logon screen to appear. I’m using the 32bit version on an AMD-based pc (as the 64bit version didn’t recognise the network).

So I installed again, turned off the kubuntu backports as suggested elsewhere in this forum and then proceeded with a system upgrade and all went well. All programs remained and the problem I had with the pager widget being unusable did not reappear. I’m happy to stay on kde 4.9 to have everything seemingly working. Maybe a note on the download page to suggest not using the kubuntu backports if a full upgrade to kde 4.10 fails might help some people.

Almost everything’s working. The clock is now keeping the right local time during reboots but I cannot select a ntp server in the settings (as before). I can run a successful manual ntpdate update so the network settings are ok. This is now a minor issue I’ll have to get back to after I’ve finished getting the system set up.

I think at this point in time the issue is caused by the presence of an upgrade to KDE 4.8.5 in the regular repos and of 4.10.1 in backports. You get two simultaneous upgrades from different repos and I thing that’s the culprit. So, after fresh install, I resolved it by removing backports first and than did an update (which upgraded KDE to 4.8.5) and only after that turned backports on again and upgraded to 4.10.1. Everything went without a hitch and all apps including Muon are in place.

I just broke Netrunner on my usb thumbdrive install (using to test a manual install of Catalyst drivers). How did I break it? Software updates. I guess it WAS a fluke. Or maybe the thumbdrive. I don’t know. Whatever, it happened when installing the second step of updates (App and Sytem unmarked). Instead of the install completing, it popped up an error about broken packages. Sure enough, all the stuff that disappears had disappeared. Don’t know what I did different. May never know. So scratch the idea from the previous post. Maybe I should have restarted TWICE after the install? …And it kicks in. I’m definitely switching gears after writing this. Got to do something else entirely for a while.

Which leads me to this question. What’s a backport and how/why turn it off/on? Are the two KDE’s trying to install as part of the Muon Update Manager process, or is that a separate thing you are doing? Netrun, or someone else, could you give an explanation how to avoid doing both at once in terms that a noob can understand? Sorry, I just started using Linux. I know what the Terminal is and how to open it. I know how to copy and paste. I know how to follow instructions. Get the idea? Thanks.

Here goes:

  • run Muon Package Manager
  • in Settings menu choose Configure Software Sources
  • select Other Software tab and look for the two urls which contain “backports” and remove them
  • then do the first update which will upgrade KDE 4.9.4 to 4.9.5
  • after that run Yakuake or Konsole(the Terminal) and execute the three following commands(one by one):
sudo add-apt-repository ppa:kubuntu-ppa/backports
sudo apt-get update
sudo apt-get dist-upgrade

Hope this helps.

P.S. Yes, I believe that upgrades to two different versions are attempted at the same time from two different sources and that’s causing this issue.

Thanks for that netrun. I contemplated turning the backports back on and continuing with the upgrade but wasn’t game enough (too many reinstalls already).
Just a small comment for BrtrdSlag, you can uncheck the backport entries in Software Sources, update, undertake the full upgrade, (restart) then recheck them and update for the repeat full upgrade. Watch to see that an update is performed after any change to the sources (I believe muon will automatically do so but just in case).

Yes, what you suggest is even easier except I don’t remember if backports were from Kubuntu or Netrunner(if it has backports repo of it’s own). Anyway it works, and I’m very happy with the distro now.:smiley:

Thanks to both of you. I’ll try that tonight.

Didn’t work… I tried three installs. The last one I did the following.

Installed Netrunner. Shutdown (to remove installer USB stick). Restarted. Went to Muon Package Manager. Noticed 1 upgradeable package. Opened Software Sources and unchecked the two backport entries (…kubuntu-ppa\backports…). Closed Software Sources window. Waited for “Updating Software Sources” and “Rebuilding Search Index.” Now 341 upgradeable packages. Clicked Check for updates. Again, 341 upgradeable. This is exactly the same thing I did the other two times up to this point.

The first time, at that point I closed MPM and opened Muon Update Manager and did install of all updates, marked and extras at once. While installing, the Muon Suite, etc. were gutted.

The second time, rather than close MPM, I clicked “Full Upgrade” then “Apply Changes,” entered password and the download began. At around 5% into the install (Committing Changes) I checked the Launcher and the gutting had occurred.

This last install, I closed MPM and restarted the PC. Then opened MPM again, checked for updates again. Then did Full Upgrade, checked for updates again which kicked me back to main MPM window so I clicked on Full Upgrade again, Apply changes, entered password, downloading packages. Again, once committing changes popped up, I clicked on the Launcher and saw that Muon was still there, but then at 4-5% it again gutted Muon, etc.

Is this even supposed to prevent Muon, etc. from being removed or are you guys talking about something else? I did notice that the second time I tried, I saw mostly attached at the end of various files (this could be my bad memory since I also tried the Terminal steps after this and that may be where I saw all of the The third time, I noticed at the end. When I say first, second, third, I mean first, second, third installations of Netrunner. I did a clean install after each failure. I thought I was doing something wrong but either the instructions aren’t clear or they just don’t work which would mean it is something else causing the issue.

Shot in the dark… The install that I got updated without issue was the only install on an HDD. No other installs were found on the system at that point (no boot loader screen). With these attempts, I was installing to a USB 3.0 32GB thumbdrive and it was creating a boot loader each time since the HDD install is present. Before the HDD install I also had dual and triple boot installs testing at once at times (that’s what caused my time issue, maybe Ultimate Edition or installing KDE desktop on Ubuntu, whatever, it stuck through later installs). I also may have installed several things on the HDD install before downloading the updates. Could extra packages installed alongside Chrome or XBMC or Disks or KNemo have something to do with it? I also noticed on my HDD install that a few new package updates have come up over the last few days. Maybe that changed something in the Full Upgrade between your attempts and mine. I don’t know. It really needs to be figured out though. Many people abandon distros for this kind of stuff. I was just wanting to get a full update on a test install for installing and testing Catalyst drivers before possibly ruining my HDD install. Hopefully, testing on the nonupdated stick install will be sufficient.

Sorry, I don’t understand what went wrong in your case.

When I did it, I didn’t tick off backports but removed them. After command-line upgrade(which is supposed to add back backports repo and upgred KDE to 4.10.1), there was immediately a notification from Muon Update that there was yet another update available. There was some warning and a selection available to choose what to update. I have chosen everything and that hasn’t been a bad choice, it seems. You haven’t mantioned what you have chosen.

That’s just it, Netrun. It’s the first updates (or something else in that step) that remove Muon. So no matter what happens after that, Muon isn’t there anymore to give a notification. Markce was able to do the same as you without removing the backports, so it’s safe to assume that either should work the same. It just didn’t work in my case. No biggie. As an aside, at least I was able to test the Catalyst drivers. It’s a bust. I don’t see any advantage to installing. The only disadvantage being potentially screwing up the install and losing the one fully updated correct install of Netrunner. So I’m sticking with the Xorg drivers, for now. Thanks for the help, though.