Netrunner 13.06 RC

Known issues:

  • firefox needs update for Webapps to install.
    solution: simply apt-get update & upgrade firefox

Just discovered netrunner, it honestly looks like the best kde distro I’ve ever tried :slight_smile:

Anyway there are a few rough edges,
1- the online accounts don’t work most of the times they display a cryptic message saying that they need to be connected to … and the message ends without saying what. When they worked (I tried with facebook) the application crashed right when I finished adding the account, obviously it was not added.

2-this is not strictly related to netrunner but it seems to be a kde bug in general so I’m not quite sure if you’ll address it, anyway new applications don’t show up when searched in the menu launcher.

As of now I just gave it a brief look on a live usb key , I’ll dig further later.

One question, when will a 64 bit image be available ? :smiley:

64bit is on the way, one more hour or so.

Can you post screenshots (hit the print key) of the failure messages of webaccounts?
Over here they seem to work fine…
Which ones particular are making trouble?

  1. which applications? firefox webapps have a UPSTREAM bug so in no Linux distro that works, but we have fixed it especially in KDE. So just update and webapps will show up in Menu. Any other apps should show up fine, so please let me know which ones make trouble… also you should try in a VM, as in LIVE-mode it could be limited RAM as everything you do runs in RAM… oh and aconadi does not run well, so that could be the reason for some webaccounts failing…which after install on a real machine or VM everything will work.

Hi! Thank you for this great KDE distro!
I don’t know is this a problem or not, but after install I have only English language. What about russian localization of overall system and applications?
In Kubuntu 13.04 for example I can add Russian localization via System Settings -> Locale module. But in Netrunner 13.06RC there is no such module in the System Settings. May be I must install this module myself?
Thank you and sorry for my english! I hope you understand me.

Hi aeromaks,
look for Locale under “Account Details”.

1.Two bugs from beta are still here (Too much groups in System Settings (Tree View), Some windows are to big, like Instant Messaging Settings in KDE Telepathy (Screen resolution 1024x768)) But this aren’t showstoppers
2. In ubiquity after choosing preferred language, not all language pack are downloaded during installation.
Manually choosing Country/Region&Language in system settings results in crash when adding new language (Polish in my case)
Works after doing apt-get update
Btw there is no possible to install additional debug packages in crash report.

Highly subjective opinion :stuck_out_tongue:
Default wallpaper is too busy for my taste :wink: Maybe it would be good idea to unify wallaper in lightdm and plasma? Enigma-Sec-Check looks like a nice candidate

  • no mouse scrolling in VirtualBox after Live-DVD loading:exclamation:
  • can’t install on drive with less 10GB space, even can’t reach partition manager because button inactive (example for format old Netrunner and install new one). Any way that your put inside why it’s so FAT? ( Any chance have selection package or group before install?, for ex. opensuse fresh install 3.6GB) There is redundancy with media players, package managers… horrible KDE games…:dodgy:. Your install way looks like in Windows. Then you must install everything but after of course you can delete things you will not going to use.
  • not wise keyboard input language. For example I’ve chose Russian, but live in Estonia, and system offer me Estonian input. I think more wise use Installer language for default input method(Other distro have the same issue)
  • auto partitioning create / as primary but swap on extended partition? Is this essential?

slimy: 32 or 64bit?

Muon update bug, This bug exists in current version (12.12) and seems sting in the new one. After refresh packages, Apply button still inactive, only muon restart helps.

  • after kernel update, restart icon in the tray not show up.
  • broken dependency with K3B which have no use on systems without any *-ROM, may be hardware dependency will be really cool to? (actually in nowadays it’s like a GRAMOPHONE), remove that program also autoremove KDE translation! This bug to from 12.12 version.

Please file a bug for Muon upstream here:

k3b bug noted to upstream kubuntu.

  • after wi-fi insert password, show up notification that Connection failed, but after few sec. Connected.
  • while prepare screen shot Krita just die in seg fault.
  • bluetooth . There before was issue that impossible click next button even BT device was selected. Possible connect only with password.
  • can’t return from Sleep Just died with black screen. I’ve tryed only in Live mode this, but I’ve tryed check another bug with touchpad then sysnaptic enabled touchpad on sleep return even then
    “Atomaticly switch off, if mouse is plugged” is enabled.

-sleep comes up fine here (installed mode).

  • wifi is a known, but nasty upstream kde bug
  • can you explain krita bug in detail?

sleep but appear then loading in UEFI mode in bios legacy wake up working correct.
There is nothing to explain sorry. It just crashed then I not use it. And I have no logs because I have finished Live session.:s I just not think that it’s related to Netrunner directly. This is not system software even no important feature.

according to this in 2.0.1 has been fixed

Great, so we will ship 2.0.1.
The issue with -nomodeset is likely upstream as well, unfortunatley no way to fix it with Netrunner packages.

I have this issue as well. Basically 99% of newly installed applications do not show up when you search for them in the search box on the main launcher. e.g if you type “appName” you get no results, you have to manually look it up on the menu. Sometimes the program doesn’t appear on the menu either. Usually after a reboot it shows up. But that’s not guaranteed.

I’m using NetRunner 12.1.

I really liked the Smaragd desktop theme from Netrunner-12.12.1. I could not find it in this new version - is it possible to get it back?

Firefox has a bug in their Marketplace!
We patched a fix though in next firefox-kde, so just update the 13.06 RC and every app sould install again fine.
Netrunner is actually the only Linux where apps will install fine then, as long as the bug persists in official Marketplace and no one else fixes firefox upstream :slight_smile:

Skyline: For 12.12.1, we will backport the fixed firefox next.

You can try installing

from here downloading the DEBS for your architecture:

Even if its not your achitecture.
copy the .deb packages in an empty folder, enter folder in konsole and type:
“sudo dpkg -i *.deb”

Actually it worked even without using the console - I opened the launchpad link you gave me with Forefox from NetRunner and right after I downloaded the correct packages you indicated they installed with the NetRunner package installer - it was an automated process. Everyting worked smoothly.

With Muon Discover (looks very good) I installed SMPlayer and, after playing around with the video settings, I got even a working VDPAU system - so HD videos work as expected.

Since the RC is not a final version, could you please add the smaragd theme files in the final isos?
Everything else (including the glass theme for the taskbar) is excellent - as it should be. And yes, with the steam installer kit - this shows that gaming can be done properly on NetRunner too - I like that a lot.

Thanks for your work.

First installation of 13.06 64 bits.
After installation, the proces hangs after ejecting the install DVD. Obliged to reset the computer to run the first time.
Country settings/region language on KDE (system settings) lead to kde crash except for american english language.
Tried an update of the system lead to allow language settings, but translation of system settings windows was only partial (mix of french and english). All french language packages are installed even gnome packages. Dolphin translation was OK. Setting a new user did not improve this behaviour.
Netrunner 12.12.1 with KDE 4.10.3 do not show this translation problem.