Netrunner Live 2016.1 hangs at boot before GUI

I am trying to boot a Live USB of netrunner 2016.1 64bit on a Dell Inspiron 15 7000 series, with an NVidia GeForce GTX graphics card. However, it always hangs at boot regardless of whether I choose default or non-free option. Also, the problem is present for UEFI and Legacy boot.

The machine came pre-installed with Ubuntu 14.04 LTS, UEFI boot. I have turned SecureBoot OFF.

When I attempt to boot netrunner, it hangs in one of 2 possible ways:

A start job is running for LiveMedia MHWD Script (no limit)

which, if I press any button, gives me the message

plymouthd: could not start boot splash: No such file or directory

Starting Wait for Plymouth Boot Screen to Quit... Starting terminate Plymouth Boot Screen...

In both cases, a hard reboot is required, since Ctrl-Alt-Del just starts another non-ending job. I’ve waited as much as 40’, jobs keep going.

I’ve burned the ISO 3-4 times, always with the same results. Manjaro 16.06.1 also hangs in the exact same way.

Output of inxi -F :

System: Host: ******** Kernel: 3.19.0-30-generic x86_64 (64 bit) Desktop: Gnome Distro: Ubuntu 14.04 trusty Machine: System: Dell product: Inspiron 7559 version: 1.1.3 Mobo: Dell model: 0H0CC0 version: A00 Bios: Dell version: 1.1.3 date: 11/05/2015 CPU: Quad core Intel Core i7-6700HQ CPU (-HT-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) Clock Speeds: 1: 800.00 MHz 2: 900.00 MHz 3: 800.00 MHz 4: 2601.00 MHz 5: 800.00 MHz 6: 800.00 MHz 7: 800.00 MHz 8: 800.00 MHz Graphics: Card: Intel Device 191b X.Org: 1.17.1 drivers: nvidia,intel Resolution: 1920x1080@60.0hz GLX Renderer: GeForce GTX 960M/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 364.19 Audio: Card: Intel Device a170 driver: snd_hda_intel Sound: ALSA ver: k3.19.0-30-generic Network: Card-1: Intel Device 3165 driver: iwlwifi IF: wlan0 state: up speed: N/A duplex: N/A mac: ***************** Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169 IF: eth0 state: down mac: ********************** Drives: HDD Total Size: 1008.2GB (0.8% used) 1: id: /dev/sda model: ST1000LM014 size: 1000.2GB 2: USB id: /dev/sdb model: DT_101_II size: 8.0GB Partition: ID: / size: 898G used: 7.5G (1%) fs: ext4 ID: swap-1 size: 16.91GB used: 0.00GB (0%) fs: swap RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present Sensors: System Temperatures: cpu: 79.0C mobo: 55.0C gpu: 57C Fan Speeds (in rpm): cpu: 44880 mobo: 37650 Info: Processes: 248 Uptime: 1 min Memory: 744.1/7857.3MB Client: Shell (bash) inxi: 1.9.17

You have a hybrid graphics system, the Intel card would be the default and the nvidia would be the secondary card.
Could you give the output of the following command?


Yes. I get:

00:00.0 Host bridge: Intel Corporation Device 1910 (rev 07) 00:01.0 PCI bridge: Intel Corporation Device 1901 (rev 07) 00:01.1 PCI bridge: Intel Corporation Device 1905 (rev 07) 00:02.0 VGA compatible controller: Intel Corporation Device 191b (rev 06) 00:04.0 Signal processing controller: Intel Corporation Device 1903 (rev 07) 00:14.0 USB controller: Intel Corporation Device a12f (rev 31) 00:14.2 Signal processing controller: Intel Corporation Device a131 (rev 31) 00:15.0 Signal processing controller: Intel Corporation Device a160 (rev 31) 00:16.0 Communication controller: Intel Corporation Device a13a (rev 31) 00:17.0 SATA controller: Intel Corporation Device a103 (rev 31) 00:1c.0 PCI bridge: Intel Corporation Device a110 (rev f1) 00:1c.4 PCI bridge: Intel Corporation Device a114 (rev f1) 00:1c.5 PCI bridge: Intel Corporation Device a115 (rev f1) 00:1c.6 PCI bridge: Intel Corporation Device a116 (rev f1) 00:1f.0 ISA bridge: Intel Corporation Device a14e (rev 31) 00:1f.2 Memory controller: Intel Corporation Device a121 (rev 31) 00:1f.3 Audio device: Intel Corporation Device a170 (rev 31) 00:1f.4 SMBus: Intel Corporation Device a123 (rev 31) 02:00.0 3D controller: NVIDIA Corporation Device 139b (rev a2) 04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10) 05:00.0 Network controller: Intel Corporation Device 3165 (rev 79) 06:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 522a (rev 01)

Try to boot disabling nouveau driver, thus forcing the system to use Intel video driver. Add the following parameter to the kernel’s boot line:



I don’t think that the nouveau driver is the issue here.
I think the issue in this case is that the Intel chip is a Skylake GPU, these are known to cause random lockups with kernels prior to 4.6.
However, you should be able to get around this disabling hardware acceleration for the Intel chip.
Just keep in mind that under Netrunner Rolling (Manjaro) the config file would be located under /etc/X11/mhwd.d/intel.conf and NOT /etc/X11/xorg.conf.d/20-intel.conf.

You could try adding nomodeset the the boot options of syslinux on the live media.

Another option would be to disable the Intel GPU in the bios (UEFI) completely, and use only the nvidia GPU.

Would this be temporary, or would I have to permanently disable the Intel GPU to install Netrunner? This seems a bit drastic.

Well, I have tried adding the following to the boot options (pressing ‘e’ at grub menu) :


None has worked. I also don’t see any options in UEFI setup about disabling Intel GPU.
Now what? :huh:

Yes and No, If you plan on keeping the 4.4 kernel on the installed system then yes, if not then you would use mhwd-kernel to install the 4.6 kernel series as these bugs were fixed in that kernel.

sudo mhwd-kernel -i linux46

To remove the current (4.4 series) kernel in the same step:

sudo mhwd-kernel -i linux46 rmc

I would normally point you to the Manjaro wiki for this, but the security certificates are still not valid for the wiki.

For the time being, I need to find a way to at least boot into the live session, otherwise I cannot update anything.

Not all laptops have this option. but to disable the intel GPU in the bios it would say something like use discrete video only or something along those lines.

I’ll check again, but IIRC, no such option in my case.

Any ideas for boot options?

If nothing else works, you might try three other, less elegant methods. Try to boot with:
[]nomodoset parameter
]vga=789 or vga=895 parameter
[*]removing the splash parameter from boot line (this will disable plymouth on boot)
[/list]Use only one option on each boot. Good luck

Which Dell Inspiron 15 7000 series is this exactly?
From my research of the motherboard listed in your inxi output, it looks like a 7559, but I need to be sure.
You may need to disable kms for both chips.

nomodeset, drm.modeset=0, nouveau.modeset=0

That’s right, it is a 7559.
I will try your instructions later today, and let you know if it worked.
What’s strange is that, from what I gather, Manjaro 16.06 should have worked – it runs a 4.4.x kernel. If everything else fails, I will even consider installing Arch.

Ok, I don’t seem to be having luck with any boot options.

The default boot options I see in UEFI boot are:

initrd=\EFI\miso\netrunner.img misobasedir=netrunner misolabel=NRRE2016 nouveau.modeset=1 1915.modeset=1 radeon.modeset=1 logo.nologo overlay=free

There is no “splash” option to remove.

OK, the live media uses syslinx and not grub, so no splash would not exist.

On the second sysliux screen you can hit F3 to select no KMS.

OK, I did some futher testing with Arch-based distros.
I managed to boot into GUI with KaOS 2016.06, setting boot options

nouveau.modeset=0 i915.modeset=1 radeon.modeset=0

AFAIK, I was using the Intel Skylake GPU in that session. KaOS Live runs a 4.6.2 kernel, which means that if I wait, some future Netrunner Rolling snapshot might possibly support my machine.

You should be able to use the same boot options using the boot option line of our live media’s syslinux screen.
Please let me know if that works or not, as the issue could be mhwd itself.

I’m a bit confused, what second syslinux screen?
At UEFI boot, I can only press ‘e’ to select boot options, F3 doesn’t seem to do anything.

In every case, I always get a “FAILED to start load kernel modules” during boot, which might indicate a MHWD bug.