NVIDIA GeForce 8200M GPU. Having major problems...

I am trying to install Netrunner on a CQ50-105NR for a friend.

Live CD works fine.
After full install the display text is huge with lines across.
Then does not boot, it repeatedly says…

nouveau failed to idle channel 1
nouveau failed to idle channel
nouveau failed to idle channel 2

I am guessing from Google searches that this is GPU related.
The laptop has the NVIDIA GeForce 8200M
Is there any way to fix this?

That’s a known nouveau driver bug, either re-install using the non-free driver option or run a system update using the following commands:

sudo rm -R /var/lib/pacman/local/bash-4.3.024-1 sudo pacman -Syy sudo pacman -S bash pacman manjaro-system sudo pacman -Su

So if I boot using the live cd.
I use those commands in the Konsole
and that will fix it?

Or how do re-install using the non-free driver option?
I dont recall seeing that option or choice along the way.
I think I would like to go the reinstall route.

I tried starting the live cd with non-free drivers and she just crashes.

No those command are not going to help from the live cd unless you chroot into the installed system:

You could possibly boot into the installed system by selecting fallback from the grub screen, this should put you into a tty (command line terminal) here you can log in and run those commands, provided you are connected to the internet via a ethernet cable to your router.

Trying to understand wiki instructions all morning. *smash my head
Am I supposed to type in this…
cd /mnt/arch

And where is a selection for fallback from grub screen?
All I get is Welcome to Grub and it just goes by fast.

If that is the directory name you created under /mnt then, yes.

(fallback) should be the second entry listed under Advanced Options for Netrunner Rolling
It shouldn’t go by fast, the default the timeout is 5 seconds.

I do not know the name, I just grabbed that from the wiki page.
So it must be cd/mnt/NetrunnerRoot
That is the default name I think.
I will go try that.
that doesnt work. I get…
bash: ch /mnt/NetrunnerRoot: No such file or directory

Do you know the right command?
It would be the default from a fresh install.
I did not change the names of anything.
i just dont understand why this is so difficult.

I need to start over from scratch…
Can you please tell me how reinstall using the non-free drivers?
Where is that option located during the installation process.

The only way to install using the non-free drivers is to boot with the non-free option from the live media, which you said doesn’t work.

oh I see.
I was not sure that was actually what you meant the first time.
nope it wont work that way.

So should I give up as far as putting linux on this computer?
Since I cant seem to get or understand how to do the chroot thing.

Have you looked for a bios update for that laptop?
Does this laptop use UEFI?
did you download the 32bit or 64bit ISO?
Did you verify the ISO with the Md5sum?
Did you burn the ISO to a DVD using the slowest burn spped or did you use a USB Stick?

Been a long day but I am making progress.
I found the fallback grub. I realized it was netrunner with advanced options.
So anyway, I am plugged into my ethernet and everything seems to be updating.

Is there any other steps I should look at taking before I restart.

Oh and the iso was the 64bit that worked perfect on the other laptops.

Well if that doesn’t fix the issue, then we can cross that bridge when we come to it. :wink:

Well…it is still a fail…*smash my head
The bottom line reads GPU lock up switching to fbcon
or something along those lines.

Then the screen goes black.

Will you help me troubleshoot more tomorrow.
I have to go to my kids basketball game now.

I hope some progress was made anyway.

The nvidia nouveau gpu lockup is a kernel issue introduced with kernel 3.16. Some distributions patched that kernel to fix the issue. Sadly this fix was not accepted upstream yet and manjaros kernel did not include that fix.
So either you use an older kernel or build your own kernel with this fix.

The easiest way would be booting with the nomodeset bootoption and installing the proprietary nvidia driver via the driver manager.

This is what I get this morning…
nouveau E DRM GPU lockup switching to software fbcon

So I will look for the nomodeset boot option.
If I can find a way in…
Ok…where is nomodeset?

On the grub screen hit e to edit and add it to the end of the “GRUB_CMDLINE_LINUX_DEFAULT=” line. then continue booting using that. This is temporary and will only work for that boot, but it will allow you to get in and install the non-free driver like leszek said.

ok i found what to do hit ‘e’ at grub menu
I added ‘nomodeset’ after ‘quiet splash’ then hit ctl+x

Now that leaves me stuck on Starting Terminate Plymouth Boot Screen…Quit…vices)…acpi_video.

Ok…I added it in the wrong place I think…
I will try again.

James…I dont have this line anywhere. “GRUB_CMDLINE_LINUX_DEFAULT=”

Its ok to add it after quiet splash. You can even replace quiet splash with nomodeset to see more debugging output.