[SOLVED] Firefox-kde fails to start after Manjaro 0.8.11 update

After performing the large 0.8.11 update firefox no longer starts:

[steve@netrunner tmp]$ firefox
XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so:
libicui18n.so.53: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

I guess I can use the firefox package (rather than the firefox-kde package). I assume the NetRunner team will be updating firefox-kde soon ?

You’ll need the Mozilla Network Security Services (NSS) package installed:

sudo pacman -S nss

I already have that package installed. I re-installed it and it made no difference.

Same problem here…

Same issue, looks like we have to wait for a fix in ‘kde-firefox’, and temporary switch to the firefox package.
It happened before:

Seeing same issue here. NSS appears to be installed. Did a restart after the upgrade. Upgraded using Octopi. Hope it is a easy fix. Thank God for multiply browsers.

I have the same problem launching Firefox after update and restart using octopi 01.12.2014.

Also, pre-launching and octopi notifier do not work after start up following this upgrade.

Happily, no probs with thunderbird or skype and midori downloaded sweetly to allow me to post this.

Triggered a recompile for firefox-kde for the blueshell repo already. Hopefully this fixes the issue.
It will take maximally one day to update the repo. Please be patient and use an alternative browser if you really need to get work done. (Konqueror, Rekonq, QupZilla, Chromium are only a few of this alternatives)

The Preload script is only for firefox-kde so until it gets updated that’s not going to work.
The octopi-notifier is working on all of my systems, I can’t reproduce.

Sadly the rebuild failed. So we have to wait for new patches to arrive to bring back kde support in firefox.
I personally recommend the usage of Chromium in the meantime. It has a good kde integration and shouldn’t have any problems with upgrading.

There also google-chrome available from the AUR, and many other alternative browsers like seamonkey, opera and palemoon to name just a few in there as well…

Do we have a time frame? As installing and setting up a new browser is time consuming.
I don’t want to be forced to use another browser if this is only a day or two kind of thing?

As have time to use a browser for work. But don’t really have the hour or three installing setting up and tweaking to usability. Then Firefox updates and then works


OK, firefox is firefox, as long as you don’t delete the config files in your home directory, all your settings and plugins will still be there.

Uninstall netrunnerarch-firefox-profile and firefox-kde

 sudo pacman -R netrunnerarch-firefox-profile firefox-kde

then install firefox:

 sudo pacman -S firefox

Now, when the kde-integration patches are released and the Netrunner developers get it compiled and available in the repositories, you can switch back just as easily.

Thanks for clarifying and will give it a go. As earlier posts about just install the other firefox didn’t quite sink in fer me.
As down to last couple of dozen neurons and they have a tendacy to spark and mis-fire sometimes! :s


[code][orbmiser@Winterfell ~]$ sudo pacman -R netrunnerarch-firefox-profile firefox-kde

error: target not found: netrunnerarch-firefox-profile

OK, so you don’t have that one installed for some reason :slight_smile:

In that case just run the second command, it will prompt you about firefox and firefox-kde being in conflict and ask if you wish to remove firefox-kde, just hit Y.

Thanks will give it a whirl.

Nada like running in circles here.

[orbmiser@Winterfell ~]$ sudo pacman -S firefox resolving dependencies... looking for inter-conflicts... :: firefox and firefox-kde are in conflict. Remove firefox-kde? [y/N] Y error: failed to prepare transaction (could not satisfy dependencies) :: firefox-kde-i18n-en-us: requires firefox-kde>=33.0

Nevermind rolled back to before the upgrade to have a working system. Strange thing is before the update was running Firefox 33.0 before upgrade. So don’t understand the error message requires firefox-kde>=33.0

Going to hold off update until a fixed firefox is in the pipe. Just surprised something so critical and used mostly by all can slip thru from Stable branch? I thought this stuff was tested before release?

Not complaining so much as really surprised by a main used application not launching after an update. Thought that would have been caught or seen by someone?

Manjaro does not provide firefox-kde so they don’t check if their update breaks it over here on netrunner rolling.
Honestly speaking I would really like Mozilla taking in the kde specific patches at least for the file open dialog and file association. That would make things a lot easier for all of us.

It’s just a dependency issue, just do the following

Sudo pacman -R firefox-kde-i18n-en-us


Sudo pacman -S firefox

and answer y when prompted.

firefox-kde-i18n-en-us is just a language pack for firefox-kde, you will just need to remove that manually as notthenewsreader suggested for the firefox installation to proceed:

sudo pacman -R firefox-kde-i18n-en-us firefox-kde
sudo pacman -S firefox

Thanks maybe later will have to redo update now before attempting again.
Still doesn’t answer my question of When? will the fixes be in the pipeline and made available thru update?
So that these kind jumping thru hoops is unnecessary.

As don’t want to have to start keeping track of manually changing things back down the road.
And with every update manually undoing things by hand.