[Solved] Flash Player on Linux and lower blocked

Getting this again and thought I just received flash upgrade?

Flash Player Plugin on Linux and lower (click-to-play) has been blocked for your protection.

Funny thing is YouTube they are just grayed out. And was working fine a couple days ago before recent upgrades.
As running on Firefox 35.0 Isn’t .429 newer and shouldn’t being blocked?

Firefox is correct here when it comes to blocking those versions. These are all vulnerable.
The newest version that isn’t vulnerable is

PS: please edit your intial thread and make the title shorter, otherwise quick reponse fails and we (the ones who want to answer) need to shorten the title manually in our answer. (See my response title as a proposel [without the RE: of course])

But that is the version installed and still getting grayed out YouTube or in site threads the one above.

The bottom one didn’t have a checkmark tho was green. Went ahead and reinstalled it manually in Octopi.
Still same problem and Firefox shows needs to be updated So confused.

Did you restart firefox after reinstalling ?

Yes rebooted and plugins showing old version.

Seems like you have maybe two different versions installed.
What is about:plugins showing you ? Maybe there are really two different plugins installed.

Also what I noticed. Why do you have lib32-flashplugin installed ? Its the 32bit flashplugin which isn’t needed when you are running firefox in a 64bit version.
So you need flashplugin also in the newest version installed.

Nope just the one and haven’t added any plugin myself just what gets installed by default.
Was working fine then after the update a couple days ago stopped working.

The confusing part is Octopi showing one installed used by others and actual flashplugin installed but not required by others?

OK do you happen to have firefox-firetray and/or thunderbird-firetray installed, they were part of one of the recent update-packs. If so then there should be a icon in your system tray that is keeping Firefox running in the background, close that tray extension and restart Firefox. You may want to remove one or both of these packages through octopi, firefox-firetray has the same basic functionality as the Netrunner startup script.

Nope not installed in fact Octopi doesn’t even show Firefox 35.0-1 installed. Which is a bit confusing for the newbie. As there is Firefox-KDE installed.

Tho do have the default pre-fetched turned on and loads at startup. Could that be an issue?


The package name would be firefox-kde not firefox, it would be at the top of the list not the bottom. :slight_smile:

Actually it’s towards the middle for me Firefox search.

Still trying to figure out why I got the flash updates but Firefox doesn’t see them.

Well, that’s the language pack and not the application package, search using firefox-kde and you’ll see it. :slight_smile:

Did you try disabling the preload script under System Settings - Startup and Shutdown?
Also have you restarted or logged out since your last update?

Yep found it further down and is installed. As haven’t ever done anything funky with Firefox just took the standard install and updates. Turned off pre-fetch and rebooted still flash issue.

[orbmiser@Winterfell ~]$ pacman -Q flashplugin

Maybe a cache issue?
You could try this, it’s not clean but looks like it works.

And this is another reason why I just use google-chrome from the AUR. LOL :slight_smile:

You could also just uninstall flashplugin and lib32-flashplugin, launch firefox, and then re-install them.

Or try creating a new profile in firefox itself.

The lib32-flashplugin wants to uninstall 29 packages with it. Some don’t know if they will be re-installed?

lib32-wayland,lib32sqlite,lib32-mesa,etc. Unfortunately Octopi does not let me resize the following packages to be removed or highlight copy to paste the contents of the dialog.

And really don’t want to create a new profile and all the extra work for something that should work. As rarely do any changes or adding or removing extensions or themes,plugins and such. Was working fine until the update.

Update: just tried the workaround from the link to manjaro thread. And worked like a charm.

Close Firefox

sudo mv /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/mozilla/plugins/libflashplayer.so.backup (to rename the plugin file)
Open Firefox and close it again
sudo mv /usr/lib/mozilla/plugins/libflashplayer.so.backup /usr/lib/mozilla/plugins/libflashplayer.so (to restore the original name)
Open Firefox again: it should not longer block Flash and show the correct version number in Add-ons Manager → Plugins

Thanks Guys for All yer Help! Appreciated!


Yes, octopi will want to uninstall all of the lib32 packages with it, pacman via the command line doesn’t do this.

I’m not sure what happened on your end, but as long as you got it fixed. :slight_smile:

I have performed this security update on two Netrunner Rolling, one Manjaro E19 and three Manjaro XFCE systems so far without issue.

PS. Could you move the [solved] tag to the beginning of your threads title instead of the end, this just makes it clearer and easier to see, thanks.

Done and Thanks again flipper for the solution thread.
Don’t Know what happened tho.


Umm, I don’t want to split hairs, but flipper gave you the link to that thread not leszek. Just sayln’. :slight_smile: