[SOLVED] Login Failure

In this past week, I have installed Netrunner17 on my work desktop (HP700-graphic card, NVIDIA, GeForce GTX 645) , and my laptop with no problem. Now I’m trying to install it on my home desktop (HP750, graphic card, NVIDIA GM107 [GeForce GTX) with no success after the installation is completed. It won’t let me login! The hard drive is encrypted through the installation process, and that’s the case with the other two computers, which it never gave me a login issue after it you enter the passphrase.

I enter the passphrase for the encryption, and it goes to the login screen. I enter my password, and it won’t take it. After a 3 to 4 try the screen goes blank, and remains blank. Nothing happens after that. I even installed it on a different SSD hard drive, just to make sure it wasn’t a hard drive issue, but same thing. It won’t let me login. I have used the same login password on the 2 other computers as well. Any expert advice will be greatly appreciated. :s

Like to mention, I just installed it on my Toshiba Tecra with no login issue. I need some expert advice, perhaps from AJSlye! :blush:

What GPU drivers are you using on these systems (free or non-free)?

I didn’t see any option to chose between free or non-free, like you see with Manjaro.

So it’s the nouveau, try adding this setting to your xorg.conf files device section:

Option "DRI" "3"

Sorry, I’m confused. During the installation, where do you get a chance to enter anything. Where is the DRI option, in the bios?

I didn’t see any such option in the bios. Another strange thing, is that when I try to re-install, I see the “Install Netrunner” icon screen for a split second, and then it jumps to the login screen. So I don’t know what’s going on.

It’s NOT a bios setting, it’s an xorg display server settings.

You can’t set this in the installer, you have to do it before logging into Plasma.
We had this issue on Arch/Manjaro already and Manjaro worked around it with mhwd.
This was later fixed by the Intel, xorg and mesa developers.

I’m still using my Manjaro on my home desktop. The funny thing I was able to install Netrunner 17 it at my work computer (HP700), which has a graphic card, NVIDIA GK106 [GeForce GTX 645], and my HP750 home desk computer, NVIDIA GM107 [GeForce GTX 745]. Everything else is the same.

The problem is There won’t be another new ISO until a couple of years from now, and I can’t afford to waste all my time with my limited knowledge to reformat the hard drive at every major update with Manjaro. I rather use a reliable Netrunner stable, and upgraded every 2, or 5 years, and not to worry at every update. I’m sure my Manjaro is not going to last that long, and it will break soon or later. Is there any other solution or some how get a newer ISO? I’m even willing to buy it if offered.

Here’s my exact specs on my computer, should this be helpful.
System: Host: HP-750xt Kernel: 4.1.1-1-MANJARO x86_64 (64 bit gcc: 5.1.0)

       Desktop: KDE Plasma 5.11.0 (Qt 5.6.1)

Machine: System: Hewlett-Packard product: 750-055xt
Mobo: Hewlett-Packard model: 2B36 v: 2.0
Bios: AMI v: 80.13 date: 05/20/2015

CPU: Quad core Intel Core i7-4790K (-HT-MCP-) cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 31937
clock speeds: max: 4000 MHz 1: 4000 MHz 2: 4000 MHz 3: 4000 MHz 4: 4000 MHz
5: 4000 MHz 6: 4000 MHz 7: 4003 MHz 8: 3999 MHz

Graphics: Card: NVIDIA GM107 [GeForce GTX 745] bus-ID: 01:00.0
Display Server: X.Org 1.17.2 driver: nvidia Resolution: 1280x1024@60.02hz
GLX Renderer: GeForce GTX 745/PCIe/SSE2
GLX Version: 4.5.0 NVIDIA 352.21 Direct Rendering: Yes

The Nvidia GTX 745 is a newer chip that the GTX 645, this would make a huge difference when it comes to the open source nouveau drivers.

Looking at your post you are not using the free drivers but the proprietary ones under Manjaro. (GLX Version: 4.5.0 NVIDIA 352.21).

After installing Netrunner 17, you’ll need to use the driver manager to install the proprietary nvidia drivers.

PS, I’ve been running the same Manjaro XFCE installation on my home PC since version 0.8.1.
I had a Manjaro 0.1.2 and up install on there previously but didn’t want to continue on with the straight Arch version of Manjaro.

Manjaro is a rolling release and NEVER needs to be reinstalled unless you mess it up yourself somehow.
Stick with the main repositories and only use the AUR if you absolutely have to, and you should never have any major issues.
I’ve only used the AUR on that system for my BROTHER all-in-one printer and scanner drivers.

Well, you’re an expert, and that’s why you’ve been using it for so long. Me, on the other hand just a causal GUI Linux user. Know enough to get around, and leaning Linux. I even test each update on my test computer, before updating the rest of the computers. Updated 5 computers with no problem with this last update from Manjaro. As soon as updated my work computer (HP700) the very next day, the grub wouldn’t load even trying 4 different kernels, but my home desktop (HP750) updated with no problem. That shouldn’t have happened! I posted the problem and heard from no one. So I reformatted to Netrunner 17, and wasted two days. Now I would like to install Netrunner 17 on my home desktop (HP750), before disaster strikes again. I’m installing it on a separate hard drive, using still my current Manjaro.

So really there isn’t any solution at this point that you know of. Do you know if Netrunner 17 coming up with any new updated ISO, before the next release?

Also I see Kunutu 16.04 LTS beta is out. Would know approximately when Netrunner 18 LTS will be available?

This has nothing to do with being an expert.
It has to do with sticking to the officially supported packages and NOT messing around installing unsupported software from the AUR unless absolutely necessary. But most importantly, never ever update the system using yaourt, you could accidentally update a required package that is a mismatched version and break your system.

As far as installing Netrunner 17 on the same system as Manjaro.
This has already been pointed out many, many times in the Manjaro forums.
If you install another Distribution that is not based on Manjaro or Arch on the same system as Manjaro, and let it manage grub, then you will NOT be able to boot back into your Manjaro installation without manual intervention and modification. This is because of the way in which Manjaro and Arch handle loading the Intel CPU microcode (ucode). You should always let Manjaro handle the main grub installation (MBR).

NOTE: Netrunner Rolling does not have this issue by default as we do not ship the system with the intel-ucode package installed.
However, if an end user installs this package themselves after install, they will have the same issue as Manjaro and Arch.

You miss-understood, I didn’t say anything about installing another Linux to the same drive.
Grub installs itself to the boot sector of the master drive by default, this has nothing to do with what drive the Linux installations are.
The main way to install another distrobution on the same system as Manjaro would be to tell it’s installer to either not install grub or to install it to it’s own partition, and then boot back into manjaro and update grub from there.

Other options would be:
Remove the intel-ucode package from your Manjaro installation.
Manually edit the grub entries on your new systems grub configuration to include the intel-ucode image of it’s Manjaro entry and update grub again.

This is an arch issue that effects also Manjaro, KaOS, Antergos, etc.
Reference: https://wiki.archlinux.org/index.php/microcode

May I ask is this a UEFI or legacy install?
Also, could you be possibly experiencing the drive encryption issue Manjaro had recently?

I see! So same thing could happen to my hp750 home computer, since I just tried to install Netrunner 17 without any success on a new SSD hard drive. I see Ubuntu as well as Manjaro in the boot order in the bios now. come to think of it, I had installed Netrunner on my hp700 work computer before I changed to Manjaro a 1.5 year ago, but I never used any of my desktop to try different Linux distribution. I use a laptop for that. I’m reading the link you sent me, but I’m afraid it’s beyond my comprehension at this point. I hope I can keep-up with it. Thanks for all your input and thoughts.

OK, back to the issue at hand.
When you get to the log in screen switch to VT2 (ctrl+alt+F2).
Next log in and edit the xorg.conf file and add Option “DRI” “3” to the device section:

sudo nano /etc/X11/xorg.conf

Go back to VT1 (ctrl+alt+F1) and hit (ctrl+alt+backspace)
Now log in.

Note: If an xorg.conf file does not already exist do the following:

sudo Xorg -configure sudo mv xorg.conf.new /etc/X11/xorg.conf
Now edit the file as described above.