[SOLVED: sddm] device manger asks for password to open usb stick in file manager

I have two netrunner 17 systems. On one I can open a usb stick in file manager via the device manager without further notices - and on the other system I get asked for the password when I click on open in file manager (same usb stick)… Why the latter? And how to get rid of the authorization?

On the “other” system where it shows the prompt do you have a second user experiencing this behavior or is it the default user ?

Please make sure that the package polkit-kde-1 is installed. It might have been removed during the upgrade to Plasma 5.5.4 in Kubuntu Backports ppa.

On both systems there is only one user and polkit-kde-1 is not installed on both systems. I’ll add it on both…

Thanks, that solved it. :slight_smile:

Alas it is not solved. After a reboot it still asks for authentification when I click on “open with file manager” in the device manager. This happens no matter which removable media device the device manager wants to mount.

Can you provide your ~/.xsession-errors file or its contents. Maybe there is an error message that could help us analyzing the problem.

It definitely is a problem of the user account. I have created a second user with the same privileges to test and I can open devices in the second account without password.

I’ll append both .xsession-errors, the one for the working account and the one for the “weird” main account.

Strange… After I mounted something in the other account I can mount without password in the main account too…

I don’t see anything useful in the two files. The working-account xsession-errors file does not seem to have any information about new devices. The second xsession-errors file has some useful information about usb sticks plugged in but sadly no error message about permission problem with mount or unmounting. Ejecting seems to work fine as it is logged there.

I am not really sure what could be the problem here. Can you check again if your users are in the plugdev group.
Also can you try this here and see if it works: http://askubuntu.com/a/552518 (Use normal konsole instead of ctrl+alt+t and kate instead of gedit)

Users are in plugdev group. Very “funny”… It does work without password if I use the second account and then the main account. But after a reboot it does not work in the main account anymore. So it’s temporarily solvable… but not persistent…

I’ve attached another xsession-errors, sorry, the former was without plugging in a usb stick.

I wanted to try editing sudo gedit /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy -
but it does not contain anything with "<action id=“org.freedesktop.udisks.filesystem-unmount…”

Apart from that it can’t be in a systemwide configuration as the other user with the same rights and groups can mount without password… Or are there somewhere systemwide stored actions for users?

And the id under details always is different.

Yeah I see now the error Not authorized to perform operation in the ~/.xsession-errors file.
Can you compare or put in here the output of ck-list-sessions on both users. Especially the one where mounting is not working. Maybe we can get something from there regarding policykit settings.

Its a process id it is meant to change :slight_smile:

Strange main account:

susanne@gemini:~$ ck-list-sessions Session1: unix-user = '1000' realname = ' Susanne' seat = 'Seat2' session-type = '' active = FALSE x11-display = ':0' x11-display-device = '/dev/tty7' display-device = '' remote-host-name = '' is-local = FALSE on-since = '2016-04-01T14:58:08.098542Z' login-session-id = '2' susanne@gemini:~$

Ok here is the problem I think: active = FALSE. So it is not detecting that the user session is active.
Can you try relogin and see if it changes anything.

And that’s the other one:

[code]rescue@gemini:~$ ck-list-sessions
unix-user = ‘1001’
realname = ‘Rescue’
seat = ‘Seat3’
session-type = ‘’
active = FALSE
x11-display = ‘:0’
x11-display-device = ‘/dev/tty7’
display-device = ‘’
remote-host-name = ‘’
is-local = FALSE
on-since = ‘2016-04-01T15:14:04.866279Z’
login-session-id = ‘4’


Also active = FALSE

The “susanne” account also has the problem that it cannot shutdown the system, no matter what I click (halt/reboot) I always get only to the login screen. I also cannot open a second user session, I always have to log out and log in as the other user.

No, does not change anything. On the other system the users are also reported as active = FALSE and no problems.

Is the process polkit-kde-authentication-agent-1 running on both sessions ?

I can check that in about an hour or two I guess, by now I’m off.

susanne@gemini:~$ ps -A | grep polkit 742 ? 00:00:00 polkitd 1436 ? 00:00:00 polkit-kde-auth

This isn’t it?