Netrunner Home

(SOLVED) YEAH Gimp help opens Okular


#22

Hey there
Well I ran as said and Ooh nice

20190501_084041

I guess I’d Have to change that , need help on that one , thanks .


#23

Well, I did find an issue and fixed it.
Just make sure you update the netrunner-settings-firefox package first.
Then run the following command: gio mime text/html firefox.desktop


#24

Did the update in octopi then this I got this

20190501_090500

Or did I do something wrong again ,


#25

No, firefox was not updated and thus did not trigger the corrected alpm hook.

Reinstall Firefox: sudo pacman -S firefox

Then run: gio mime text/html firefox.desktop


#26

Gee whiskers which one ,

20190501_093947

i would go for N ?

need some help dont want to mess things up


#27

Yes, to remove firefox-kde-opensuse, we no longer use that package, it will be replaced with the upstream Firefox package. The firefox-kde-opensuse package will soon be dropped from the Manjaro repositories.

We now use portal, portal-kde, the plasma browser integration package, and and the plasma integration plug-in instead. The firefox.desktop diversion is what needed to be fixed for gio. Gio seams to be extremely finicky about the command line format in *.desktop files…


#28

updated and removed the files Firefox needed , what happens now ?

Just tried Gimp help same ole story .


#29

OK, what do you mean by “updated and removed the files Firefox needed”.
All you needed to do was let pacman remove the firefox-kde-opensuse package and install firefox.
This would have triggered the pacman (alpm) hook and fix the firefox.desktop files exec lines.

Then you could run: gio mime text/html firefox.desktop
After that html should be set to firefox.desktop for gio.


#30

This does not look right ?


#31

What version number is the netrunner-settings-firefox package on your system?
Can you post the exec= lines of your /usr/share/applications/firefox.desktop file?

You should be getting:

$ gio mime text/html firefox.desktop
Set firefox.desktop as the default for text/html

#32

Actually, lets just try this again from scratch:

sudo pacman -S netrunner-settings-firefox firefox
gio mime text/html firefox.desktop

#33

Hopefully this is

20190501_102744

20190501_102712

This is getting to be hard work for you
I do apologize it was never meant to be this big


#34

OK, I see the problem.
The version of netrunner-settings-firefox should be 2019.04-6, and the exec lines should now read as:
Exec=/usr/bin/sh -c “GTK_USE_PORTAL=1 /usr/lib/firefox/firefox %u”
Exec=/usr/bin/sh -c “GTK_USE_PORTAL=1 /usr/lib/firefox/firefox --new-window %u”
Exec=/usr/bin/sh -c “GTK_USE_PORTAL=1 /usr/lib/firefox/firefox --private-window %u”

Like I said, gio seems to be extremely finicky about the exec lines formatting.


#35

how is it that has happened and is this just me ( no-one else has posted similar )
I don’t recall doing any changes and the downloaded iso was verified

this to me my understanding is strange behavior ?
Is this something I’ve done ?
and if so , How ?
I’m lost here


#36

IDK, it’s hard for me to know what you may, or may not have done. :wink:

I just know that you need to update that package and possibly more:
sudo pacman -Syu


#37

done


#38

OK now:
gio mime text/html firefox.desktop

Then if that goes right, test gimp


#39

Ooh ( censored )

20190501_112018


#40

OK, then:
sudo pacman -S firefox
one more time to trigger the pacman hook.

The pacman hook is what fixes the exec lines in firefox.desktop.

Now gio mime text/html firefox.desktop should work.

Stll, I wish I knew why you have no mimetype at all set for html.


#41

So is this good Y/N ?

20190501_112746